Author yselivanov
Recipients asvetlov, fried, hniksic, lukasz.langa, yselivanov
Date 2018-05-17.16:42:48
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1526575368.72.0.682650639539.issue33544@psf.upfronthosting.co.za>
In-reply-to
Content
> Deprecating Event.wait would be incorrect because Event was designed to mimic the threading.Event class which has a (blocking) wait() method[1].

This is rather important. I'd like to continue maintaining this similarity. Adding 'await event' would be similar (in a way) to making instances of threading.Event callable.  So deprecation of '.wait()' isn't something we will do.

Having *both* 'await event.wait()' and 'await event' worries me.  IMO the slight readability improvement isn't worth the added complexity.
History
Date User Action Args
2018-05-17 16:42:48yselivanovsetrecipients: + yselivanov, hniksic, asvetlov, lukasz.langa, fried
2018-05-17 16:42:48yselivanovsetmessageid: <1526575368.72.0.682650639539.issue33544@psf.upfronthosting.co.za>
2018-05-17 16:42:48yselivanovlinkissue33544 messages
2018-05-17 16:42:48yselivanovcreate