This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author dplusplus
Recipients dplusplus, jpc2350, ned.deily
Date 2018-05-11.03:27:09
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
I am trying to build Python 3.6.5 from source, with Tcl 8.6.8 and Tk 8.6.8, and I get the same issue (Building on Ubuntu 18.04, tried with GCC 7.3 and 8.1 with same results). 
Run 'readelf -d` on 'build/lib.linux-x86_64-3.6/' and I get three NEEDED entries:

 0x0000000000000001 (NEEDED)             Shared library: []
 0x0000000000000001 (NEEDED)             Shared library: []
 0x0000000000000001 (NEEDED)             Shared library: []

Tcl and Tk libraries are not listed as needed shared libraries, which explains why settings runpaths (which I tried by setting CFLAGS) does not seem to work.
I'm comparing this to the ELF entries in Ubuntu's Python 3.6.5 tkinter module '/usr/lib/python3.6/lib-dynload/', which does have NEEDED entries for and
Date User Action Args
2018-05-11 03:27:10dplusplussetrecipients: + dplusplus, ned.deily, jpc2350
2018-05-11 03:27:10dplusplussetmessageid: <>
2018-05-11 03:27:10dpluspluslinkissue31817 messages
2018-05-11 03:27:09dpluspluscreate