Author bskinn
Recipients Anthony Sottile, bethard, bskinn, eric.araujo, memeplex, paul.j3, wolma
Date 2018-05-07.16:05:19
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1525709119.27.0.682650639539.issue33109@psf.upfronthosting.co.za>
In-reply-to
Content
I second Wolfgang's recommendation to change the default back to `False`.

I started developing CLI apps &c. in Python ~4yrs ago; I dabbled briefly in 2.7, then switched firmly to Python 3.  When I started, I was aimed at supporting 3.3 to 3.5; now I'm specifically supporting 3.4 to 3.6, but starting to test my code against the 3.7b versions.

Thus, all I've ever known is the default `required=False` behavior. On my one tool currently using subparsers (https://github.com/bskinn/sphobjinv), I made the subparser choice optional, to allow a `sphobjinv --version` invocation. So, when 3.7 failed that test (https://github.com/bskinn/sphobjinv/blob/6c1f22e40dc3d129485462aec05adbed2ff40ab8/sphobjinv/test/sphobjinv_cli.py#L419-L422), it seemed like a regression to me.

All that said, given that the `subparsers.required = False` fix is a clean, single line, I have no beef with a `True` default if that's preferred. However, please include this change in the 3.7 CHANGELOG, at least.
History
Date User Action Args
2018-05-07 16:05:19bskinnsetrecipients: + bskinn, bethard, eric.araujo, memeplex, paul.j3, wolma, Anthony Sottile
2018-05-07 16:05:19bskinnsetmessageid: <1525709119.27.0.682650639539.issue33109@psf.upfronthosting.co.za>
2018-05-07 16:05:19bskinnlinkissue33109 messages
2018-05-07 16:05:19bskinncreate