Author mark.dickinson
Recipients mark.dickinson, serhiy.storchaka
Date 2017-04-01.15:17:28
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1491059848.98.0.426976127535.issue29962@psf.upfronthosting.co.za>
In-reply-to
Content
> Shouldn't the new function be named math.remainder_near?

Not clear. :-) I'd prefer to keep the name that's consistent with both C and IEEE 754. (We already have plenty of naming differences between Decimal and math; attempting to reconcile them is likely futile.)

FTR:

IEEE 754: remainder
C99: remainder
IBM Decimal spec: remainder-near
Java: IEEEremainder
.NET: IEEERemainder
History
Date User Action Args
2017-04-01 15:17:29mark.dickinsonsetrecipients: + mark.dickinson, serhiy.storchaka
2017-04-01 15:17:28mark.dickinsonsetmessageid: <1491059848.98.0.426976127535.issue29962@psf.upfronthosting.co.za>
2017-04-01 15:17:28mark.dickinsonlinkissue29962 messages
2017-04-01 15:17:28mark.dickinsoncreate