Author zach.ware
Recipients docs@python, eric.araujo, ezio.melotti, georg.brandl, martin.panter, python-dev, terry.reedy, vstinner, zach.ware
Date 2016-08-25.15:20:23
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1472138423.68.0.843661697906.issue26638@psf.upfronthosting.co.za>
In-reply-to
Content
The syntax is `<pip> install "<package><comparison><version>"`, so in this case 'pip install "Sphinx==1.3.6"` (or `pip install "Sphinx<1.4"`) should do it for you.  That ought to also take care of downgrading any other packages that need it (though I don't think there are any), or at least tell you which ones should be downgraded and to what.

I'm not sure why there are both `pip list` and `pip freeze`, but `pip freeze` is the one that outputs usable syntax for a requirement specifier.
History
Date User Action Args
2016-08-25 15:20:23zach.waresetrecipients: + zach.ware, georg.brandl, terry.reedy, vstinner, ezio.melotti, eric.araujo, docs@python, python-dev, martin.panter
2016-08-25 15:20:23zach.waresetmessageid: <1472138423.68.0.843661697906.issue26638@psf.upfronthosting.co.za>
2016-08-25 15:20:23zach.warelinkissue26638 messages
2016-08-25 15:20:23zach.warecreate