This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author rhettinger
Recipients ethan.furman, loewis, palaviv, rhettinger
Date 2016-04-28.06:42:47
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1461825767.87.0.446892580426.issue26860@psf.upfronthosting.co.za>
In-reply-to
Content
Classes are normally named with CamelCase.  Also, "walk_result" or "WalkResult" seems like an odd name that doesn't really fit.   DirEntry or DirInfo is a better match (see the OP's example, "for dir_entry in walk_it: ...")

The "versionchanged" should be a "versionadded".

The docs should use "named tuple" instead of "namedtuple".  The former is the generic term used in the glossary to describe the instances.  The latter is the factory function that creates a new tuple subclass.

The attribute descriptions for the docs are pretty good.  They should also be applied as actual docstrings in the code as well.

The docs and code for fwalk() needs to be harmonized with walk() so the the tuple fields use the same names:  change (root, dirs, files) to (dirpath, dirnames, filenames).
History
Date User Action Args
2016-04-28 06:42:48rhettingersetrecipients: + rhettinger, loewis, ethan.furman, palaviv
2016-04-28 06:42:47rhettingersetmessageid: <1461825767.87.0.446892580426.issue26860@psf.upfronthosting.co.za>
2016-04-28 06:42:47rhettingerlinkissue26860 messages
2016-04-28 06:42:47rhettingercreate