Author markroseman
Recipients Alessandro Rosa, markroseman, ned.deily, ronaldoussoren, taleinat, terry.reedy, wordtech
Date 2015-08-12.23:13:01
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1439421181.17.0.149429813824.issue24570@psf.upfronthosting.co.za>
In-reply-to
Content
I did some followup on this today, and could reproduce it with a few lines of Tcl/Tk code. As Ned noted, it seems particular to the ActiveTcl build, as when I built my own 8.5.18 it also worked fine.

(If you're curious, the thing that is failing is the MacWindowStyle call to set the window to type "help". If you use that, the window just doesn't show up. Oddly, other types, e.g. "utility" work properly).

I tried various introspection techniques to see if I could detect that this problem had occurred from code, but no luck. As far as Tk was concerned, the window was there.

Will send a message to tcl-core list regarding this. For reference, Tcl script to reproduce is:

wm geometry . +32+32
toplevel .t
wm geometry .t +60+60
tk::unsupported::MacWindowStyle style .t help "noActivates"
grid [label .t.l -bg yellow -text "tooltip window"]
History
Date User Action Args
2015-08-12 23:13:01markrosemansetrecipients: + markroseman, terry.reedy, ronaldoussoren, taleinat, wordtech, ned.deily, Alessandro Rosa
2015-08-12 23:13:01markrosemansetmessageid: <1439421181.17.0.149429813824.issue24570@psf.upfronthosting.co.za>
2015-08-12 23:13:01markrosemanlinkissue24570 messages
2015-08-12 23:13:01markrosemancreate