Author steve.dower
Recipients Arfrever, barry, brett.cannon, eric.snow, lemburg, ncoghlan, ned.deily, pitrou, steve.dower, tim.golden, vstinner, zach.ware
Date 2014-12-06.20:11:39
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1417896699.72.0.657372583636.issue22980@psf.upfronthosting.co.za>
In-reply-to
Content
What can I do to help move this along?

It sounds like for Windows builds we could change _imp.extension_suffixes() from ['.pyd'] to ['.{}.pyd'.format(distutils.util.get_platform()), '.pyd'] and update distutils to produce the more specific name (I've got some work to do on distutils anyway for 3.5, so I'm happy to do this part). This would also include somehow hard-coding the get_platform() result into the executable (probably a #define in pyconfig.h)

I'm more inclined towards get_platform() than adding new architecture tags. Windows at least doesn't support fat binaries - the closest equivalent is universal apps, which use separate binaries and a naming convention. Adding a debug marker here would also be nice, as I've never been a huge fan of the "_d" suffix we currently have, but it's not a big deal.

I suspect any changes here would be completely separate from other platforms, but ISTM that we're looking at a similar change to handle the bitness/debug issue on Linux. I'm not volunteering to do that part :)
History
Date User Action Args
2014-12-06 20:11:39steve.dowersetrecipients: + steve.dower, lemburg, barry, brett.cannon, ncoghlan, pitrou, vstinner, tim.golden, ned.deily, Arfrever, eric.snow, zach.ware
2014-12-06 20:11:39steve.dowersetmessageid: <1417896699.72.0.657372583636.issue22980@psf.upfronthosting.co.za>
2014-12-06 20:11:39steve.dowerlinkissue22980 messages
2014-12-06 20:11:39steve.dowercreate