This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author yselivanov
Recipients Antony.Lee, georg.brandl, ncoghlan, serhiy.storchaka, yselivanov
Date 2014-09-26.21:54:18
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <>
Antony, I agree regarding the poor naming of '_sanitize_dir()' helper. As for your other suggestion, I think such a refactoring will actually make code harder to follow (+ it's more invasive). Generally, I'm in favour of transforming parameters like 'dir' closer to the beginning of the method's code, so that it's immediately obvious what's going on, and is also easier to put debug code [like 'print("mkdtemp call for: ", dir)'].
Date User Action Args
2014-09-26 21:54:18yselivanovsetrecipients: + yselivanov, georg.brandl, ncoghlan, serhiy.storchaka, Antony.Lee
2014-09-26 21:54:18yselivanovsetmessageid: <>
2014-09-26 21:54:18yselivanovlinkissue20267 messages
2014-09-26 21:54:18yselivanovcreate