Author vstinner
Recipients akira, neologix, pitrou, vstinner
Date 2014-07-28.12:39:20
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1406551160.89.0.051155539073.issue22054@psf.upfronthosting.co.za>
In-reply-to
Content
> Maybe is_something() is a better name than get_something()
> if something is a boolean?

os and socket modules already use getxxx() / setxxx() names:

- os.get_inheritable() / os.set_inheritable()
- os.getuid() / os.setuid()
- os.getgroups() / os.setgroups()
- os.getxattr() os.setxattr()
- socket.gettimeout() / socket.settimeout()
- socket.get_inheritable() / socket.set_inheritable()
- etc.

There is only one "is" function: os.isatty(), but it does not have a "os.settty" method.
History
Date User Action Args
2014-07-28 12:39:20vstinnersetrecipients: + vstinner, pitrou, neologix, akira
2014-07-28 12:39:20vstinnersetmessageid: <1406551160.89.0.051155539073.issue22054@psf.upfronthosting.co.za>
2014-07-28 12:39:20vstinnerlinkissue22054 messages
2014-07-28 12:39:20vstinnercreate