Author ncoghlan
Recipients Arfrever, brett.cannon, eric.snow, ncoghlan, python-dev, serhiy.storchaka
Date 2013-12-19.11:06:50
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1387451211.22.0.318082146069.issue19713@psf.upfronthosting.co.za>
In-reply-to
Content
Please don't emit a deprecation warning for loaders that only implement load_module - there are still things load_module can do that create/exec can't, and it's still possible it will remain the long term API for those use cases.

Plus builtins and extensions are still loaded with load_module - we can't deprecate an API we're still using.

I'm actually still -0 on doing any programmatic deprecations in 3.4 at all. What maintenance burden are we eliminating for ourselves that justifies the pain we're inflicting on users? I want import system specialists to be *excited* about PEP 451, but if we deprecate everything and *force* them to migrate immediately (rather than giving them until 3.5 before they get warnings), they're going to hate it :(
History
Date User Action Args
2013-12-19 11:06:51ncoghlansetrecipients: + ncoghlan, brett.cannon, Arfrever, python-dev, eric.snow, serhiy.storchaka
2013-12-19 11:06:51ncoghlansetmessageid: <1387451211.22.0.318082146069.issue19713@psf.upfronthosting.co.za>
2013-12-19 11:06:51ncoghlanlinkissue19713 messages
2013-12-19 11:06:50ncoghlancreate