Author r.david.murray
Recipients ivan.radic, r.david.murray, tim.golden, zach.ware
Date 2013-11-18.19:24:13
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1384802653.85.0.680450566707.issue19643@psf.upfronthosting.co.za>
In-reply-to
Content
That's not a good name for the flag.  The problem is that 'read-only' means different things on Windows than it does on Unix.  Which is why I suggested that the flag control whether or not it acts "posix like" on Windows.  So perhaps 'posix_compat'?  That feels a bit odd, though, since on posix it does nothing...so it's really about behavioral consistency across platforms....

Hmm.  It's really hard to think of a name that conveys succinctly what we are talking about here.

A more radical notion would be something like 'delete_control' and have it be tri-valued: 'unixlike', 'windowslike', and 'native', with the default being native.  Bad names, most likely, but you get the idea.  The disadvantage is that it would be even more code to implement ;)
History
Date User Action Args
2013-11-18 19:24:13r.david.murraysetrecipients: + r.david.murray, tim.golden, zach.ware, ivan.radic
2013-11-18 19:24:13r.david.murraysetmessageid: <1384802653.85.0.680450566707.issue19643@psf.upfronthosting.co.za>
2013-11-18 19:24:13r.david.murraylinkissue19643 messages
2013-11-18 19:24:13r.david.murraycreate