Author pitrou
Recipients barry, ezio.melotti, georg.brandl, pitrou, r.david.murray, steven.daprano, vajrasky
Date 2013-08-05.18:36:11
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1375727763.2557.3.camel@fsol>
In-reply-to <1375715666.8.0.768627669498.issue18585@psf.upfronthosting.co.za>
Content
> Looking just at the proposed functionality (taking a prefix) and
> ignoring the requested complexification :), the usual name for the
> text produced by this process is a
> "lead" (http://en.wikipedia.org/wiki/Wikipedia:Manual_of_Style/Lead_section), although formally a lead is actually written to be used as such, as opposed to just taking a prefix, so that word really has the same problem as 'summarize'.

Good point.

> The placeholder argument could alternatively be named 'ellipsis', but
> placeholder is certainly fine.

I would certainly like ellipsis if it didn't already mean something else
in Python.

> shorten would probably be better if you are going with the expanded
> version, but I like truncate.  It is probably significant that that is
> what the title of the issue calls it :)

I'm a bit negative towards truncate(), mostly because I've worked on the
I/O stack and truncate means something much less careful there (e.g.
StringIO.truncate()).
But really, I'm fine with either shorten() or truncate(). I agree
summarize() may try to look a bit too smart.
History
Date User Action Args
2013-08-05 18:36:11pitrousetrecipients: + pitrou, barry, georg.brandl, ezio.melotti, steven.daprano, r.david.murray, vajrasky
2013-08-05 18:36:11pitroulinkissue18585 messages
2013-08-05 18:36:11pitroucreate