Author tim.peters
Recipients hynek, loewis, lukasz.langa, mark.dickinson, ncoghlan, r.david.murray, rhettinger, serhiy.storchaka, tim.peters
Date 2013-08-04.23:46:34
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1375659994.62.0.284910996846.issue18652@psf.upfronthosting.co.za>
In-reply-to
Content
> skipping the underscore ("firsttrue" or "nexttrue")
> would arguably be more consistent with other itertools names.

Like izip_longest and combinations_with_replacement? ;-)

I care about readability here more than consistency with the bulk of itertools names.  "first" ends with "t" and "true" begins with "t", which makes "firsttrue" an eyesore.  "first_true" strikes me as very easy to read, spell, remember and understand.

Offhand I don't know what "nexttrue" is supposed to mean (like "if that's supposed to mean the first true iterate, why didn't they say 'first' instead of 'next'?").
History
Date User Action Args
2013-08-04 23:46:34tim.peterssetrecipients: + tim.peters, loewis, rhettinger, mark.dickinson, ncoghlan, r.david.murray, lukasz.langa, hynek, serhiy.storchaka
2013-08-04 23:46:34tim.peterssetmessageid: <1375659994.62.0.284910996846.issue18652@psf.upfronthosting.co.za>
2013-08-04 23:46:34tim.peterslinkissue18652 messages
2013-08-04 23:46:34tim.peterscreate