Author v+python
Recipients amcnabb, bethard, docs@python, guilherme-pg, paul.j3, r.david.murray, v+python
Date 2013-04-24.01:11:55
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1366765915.74.0.990934702291.issue14191@psf.upfronthosting.co.za>
In-reply-to
Content
Yes, a second function would give more flexibility.

Due to the "approval" in msg166175 to use the name parse_intermixed_args for the functionality described there, it would probably be best to use that name for that functionality.

So then we are left naming your current function something else. parse_known_intermixed_args certainly is descriptive, and fits the naming conventions of the other methods in the class. Quite long, unfortunately... but then I doubt it will get used much. I am using parse_intermixed_args regularly (via my wrapper class), and it is quite long enough.
History
Date User Action Args
2013-04-24 01:11:55v+pythonsetrecipients: + v+python, amcnabb, bethard, r.david.murray, docs@python, paul.j3, guilherme-pg
2013-04-24 01:11:55v+pythonsetmessageid: <1366765915.74.0.990934702291.issue14191@psf.upfronthosting.co.za>
2013-04-24 01:11:55v+pythonlinkissue14191 messages
2013-04-24 01:11:55v+pythoncreate