Author chris.jerdonek
Recipients asvetlov, chris.jerdonek, christian.heimes, eric.araujo, ezio.melotti, gregory.p.smith, lyapun, neologix, pitrou, r.david.murray, tim.golden
Date 2012-11-05.10:25:49
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1352111149.63.0.684988660687.issue16353@psf.upfronthosting.co.za>
In-reply-to
Content
> Any interest in doing like os.get_terminal_size/shutil.get_terminal_size

If functions with two different behaviors are needed, I think the two functions should probably have different names (e.g. get_shell() and get_user_shell()).  Otherwise, it may create confusion as to which to call (or which is being called when reading code).

Moreover, it doesn't seem like the following guidance in the docs for which get_terminal_size() to use would hold in parallel for the shell variants: "shutil.get_terminal_size() is the high-level function which should normally be used, os.get_terminal_size is the low-level implementation."
History
Date User Action Args
2012-11-05 10:25:49chris.jerdoneksetrecipients: + chris.jerdonek, gregory.p.smith, pitrou, christian.heimes, tim.golden, ezio.melotti, eric.araujo, r.david.murray, asvetlov, neologix, lyapun
2012-11-05 10:25:49chris.jerdoneksetmessageid: <1352111149.63.0.684988660687.issue16353@psf.upfronthosting.co.za>
2012-11-05 10:25:49chris.jerdoneklinkissue16353 messages
2012-11-05 10:25:49chris.jerdonekcreate