Author Nicholas.Cole
Recipients Nicholas.Cole, cben, georg.brandl, gpolo, inigoserna, jcea, ned.deily, phep, pitrou, python-dev, r.david.murray, vstinner
Date 2012-09-03.12:57:33
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1346677054.54.0.619733462979.issue14223@psf.upfronthosting.co.za>
In-reply-to
Content
> Unless I'm getting the build process wrong (possible, because
> I haven't tried testing fixes before), this fix isn't working for me.

Oh did you compile Python? Did you install it?

Yes, I tried compiling it.  

#./configure MACOSX_DEPLOYMENT_TARGET=10.8 --enable-framework --with-universal-archs="64-bit" CFLAGS="-arch x86_64" LDFLAGS="-arch x86_64" && make -j6 && make install

Do you have libncursesw? => do you have the function curses.unget_wch?

yes...

Python 3.3.0rc1+ (default, Sep  3 2012, 09:45:35) 
[GCC 4.2.1 Compatible Apple Clang 4.0 ((tags/Apple/clang-421.0.57))] on darwin
Type "help", "copyright", "credits" or "license" for more information.
>>> import curses
>>> curses.unget_wch()
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
_curses.error: must call initscr() first
>>> curses.version
b'2.2'
>>> 


What is the version of your libcurses[w] library? There are issues on libncurses 5.7. I think Ned Bat changed the script to compile Python on Mac to use a builtin copy of libncurses 5.9. See:
http://bugs.python.org/issue14225#msg163323

How do I check which version it was built against?  The messages from ./configure just say that the tests pass, not which version it has found.
History
Date User Action Args
2012-09-03 12:57:34Nicholas.Colesetrecipients: + Nicholas.Cole, georg.brandl, jcea, cben, pitrou, vstinner, gpolo, ned.deily, r.david.murray, inigoserna, phep, python-dev
2012-09-03 12:57:34Nicholas.Colesetmessageid: <1346677054.54.0.619733462979.issue14223@psf.upfronthosting.co.za>
2012-09-03 12:57:33Nicholas.Colelinkissue14223 messages
2012-09-03 12:57:33Nicholas.Colecreate