Author trent
Recipients loewis, ned.deily, petri.lehtinen, python-dev, sbt, trent
Date 2012-08-31.13:19:08
SpamBayes Score -1.0
Marked as misclassified Yes
Message-id <1346419149.67.0.667858316622.issue15819@psf.upfronthosting.co.za>
In-reply-to
Content
Well, that escalated quickly :-)

I think I should clarify my use case that resulted in raising this bug.

1. Create a fresh hg clone, say, ~/hg/cpython-3.2.
2. Make it readonly: `zfs set readonly=on tank/home/cpython/hg/cpython-3.2`
3. cd /tmp/cpython-3.2-build
4. /home/cpython/hg/cpython-3.2/configure --srcdir=/home/cpython/hg/cpython-3.2/configure

So, my patches address that use case.  The thing I like about the approach above is that I can set the source directory to readonly immediately -- I don't have to do an intermediate ./configure in that directory in order to generate a Makefile so I can `make touch`.  (Side note: I'm almost certain `make touch` wouldn't work for my use case.)

Richard: what was your use case?  What steps did you take that resulted in getting typeslots.inc and _sysconfigdata.py written to?

....although I just tried an out-of-tree build with 'default' using the exact steps above and got the same error with _sysconfigdata.py.

Martin: I think I understand your arguments, and I (think) I agree with them.  Especially your last point with regards to always running ASDLGEN.

I think I'm +1 on reverting and trying the '-' approach originally used by Neil.
History
Date User Action Args
2012-08-31 13:19:09trentsetrecipients: + trent, loewis, ned.deily, python-dev, sbt, petri.lehtinen
2012-08-31 13:19:09trentsetmessageid: <1346419149.67.0.667858316622.issue15819@psf.upfronthosting.co.za>
2012-08-31 13:19:09trentlinkissue15819 messages
2012-08-31 13:19:08trentcreate