Author ncoghlan
Recipients hynek, jcea, ncoghlan, neologix, pitrou, rosslagerwall, tarek
Date 2012-01-31.12:27:15
SpamBayes Score 7.78971e-05
Marked as misclassified No
Message-id <1328012836.57.0.84162505274.issue13734@psf.upfronthosting.co.za>
In-reply-to
Content
Taking a closer look at the current naming scheme in the os module, fdopen() appears to be the only current function that uses the 'fd' prefix. All the other operations that accept a file descriptor just use 'f' as the prefix (fchmod, fchown, faccess, etc).

Given that, flistdir() and fwalk() seem like the most consistent choices of name for APIs that aren't directly matching an underlying POSIX function name.
History
Date User Action Args
2012-01-31 12:27:16ncoghlansetrecipients: + ncoghlan, jcea, pitrou, tarek, neologix, rosslagerwall, hynek
2012-01-31 12:27:16ncoghlansetmessageid: <1328012836.57.0.84162505274.issue13734@psf.upfronthosting.co.za>
2012-01-31 12:27:16ncoghlanlinkissue13734 messages
2012-01-31 12:27:15ncoghlancreate