Author diegoqueiroz
Recipients diegoqueiroz, eric.araujo, tarek
Date 2011-01-19.21:30:12
SpamBayes Score 7.26316e-09
Marked as misclassified No
Message-id <1295472618.01.0.686461306888.issue10948@psf.upfronthosting.co.za>
In-reply-to
Content
You were right, "os.makedirs" fits my needs. :-)

Anyway, I still think the change in the documentation is needed.
This is not an implementation detail, it is part of the way the function works.

The user should be aware of the behavior when he call this function twice. In my opinion, the documentation should be clear about everything. We could call this an implementation detail iff it does not affect anything externally, but this is not the case (it affects subsequent calls).

This function does exactly the same of "os.makedirs" but the why is discribed only in a comment inside the code. We know this is a poor programming style. This information need to be available in the documentation too.
History
Date User Action Args
2011-01-19 21:30:18diegoqueirozsetrecipients: + diegoqueiroz, tarek, eric.araujo
2011-01-19 21:30:18diegoqueirozsetmessageid: <1295472618.01.0.686461306888.issue10948@psf.upfronthosting.co.za>
2011-01-19 21:30:12diegoqueirozlinkissue10948 messages
2011-01-19 21:30:12diegoqueirozcreate