Author bethard
Recipients belopolsky, bethard, eric.araujo, eric.smith, georg.brandl
Date 2010-12-03.09:22:34
SpamBayes Score 1.06905e-07
Marked as misclassified No
Message-id <1291368158.8.0.930984329341.issue10528@psf.upfronthosting.co.za>
In-reply-to
Content
If I understand it right, before this patch, people couldn't really supply internationalizations for these calls - they would have had to have a translation for each possible value of, e.g. action.choices or parser.prefix_chars. So I think there's pretty minimal danger of breaking that code.

Specific comments on names in the patch:

* rename %(character) to %(prefix_chars)
* rename %(name) to %(type) and %(arg_string) to %(value)
* rename %(program_name) to %(prog)

Basically, we should use the name of an Action or ArgumentParser attribute whenever it makes sense. Hopefully that will make it more intuitive what these mean when people are translating them.

And yes, with the above changes, +1.
History
Date User Action Args
2010-12-03 09:22:38bethardsetrecipients: + bethard, georg.brandl, belopolsky, eric.smith, eric.araujo
2010-12-03 09:22:38bethardsetmessageid: <1291368158.8.0.930984329341.issue10528@psf.upfronthosting.co.za>
2010-12-03 09:22:34bethardlinkissue10528 messages
2010-12-03 09:22:34bethardcreate