Message123206
Alexander Belopolsky wrote:
>
> Alexander Belopolsky <belopolsky@users.sourceforge.net> added the comment:
>
> I am probably a bit late to this discussion, but why these things should be called "codecs" and why should they share the registry with the encodings? It looks like the proper term would be "transformations" or "transforms".
.transform() is just the name of the method. The codecs are still just
that: codecs, i.e. objects that encode and decode data. The types they
support are defined by the codecs, not by the helper methods.
In Python3, the str and bytes methods .encode() and .decode() will
only support str->bytes->str conversions. The new
str and bytes .transform() method adds back str->str and
bytes->bytes.
The codec subsystem does not impose restrictions on the type combinations
a codec can support, and that's per design. |
|
Date |
User |
Action |
Args |
2010-12-03 08:46:30 | lemburg | set | recipients:
+ lemburg, loewis, georg.brandl, belopolsky, vstinner, benjamin.peterson, eric.araujo, ssbarnea, flox |
2010-12-03 08:46:28 | lemburg | link | issue7475 messages |
2010-12-03 08:46:28 | lemburg | create | |
|