Author ncoghlan
Recipients georg.brandl, ncoghlan, rhettinger
Date 2010-11-30.04:12:03
SpamBayes Score 0.000130292
Marked as misclassified No
Message-id <1291090329.24.0.356278659224.issue10586@psf.upfronthosting.co.za>
In-reply-to
Content
As per private email to Raymond, I would like to move the lru_cache access attributes and methods into a CacheInfo class, exposed as a "cache" attribute with several methods and read-only properties.

Read-only properties: hits, misses, maxsize
Methods: clear(), __len__()

As an implementation detail, cache_misses and cache_hits become nonlocal variables rather than attributes of the wrapper function.

Priority set to high, since the current API will be locked in as soon the first beta goes out.
History
Date User Action Args
2010-11-30 04:12:09ncoghlansetrecipients: + ncoghlan, georg.brandl, rhettinger
2010-11-30 04:12:09ncoghlansetmessageid: <1291090329.24.0.356278659224.issue10586@psf.upfronthosting.co.za>
2010-11-30 04:12:04ncoghlanlinkissue10586 messages
2010-11-30 04:12:04ncoghlancreate