Author pitrou
Recipients georg.brandl, jyasskin, kristjan.jonsson, pitrou
Date 2010-11-02.11:29:02
SpamBayes Score 4.10396e-06
Marked as misclassified No
Message-id <1288697339.3549.1.camel@localhost.localdomain>
In-reply-to <1288657753.33.0.884410299435.issue10260@psf.upfronthosting.co.za>
Content
> I spent some time thinking of a name.  I tried wait_predicate and
> predicate_wait, but wait_for seemed natural.  Any other ideas?
> How about wait_until_true?

wait_for is ok IMO.

> My original method had this as a free function, but I moved it into
> the Condition because I could see no other kind of primitive that
> would use it.  I agree that it is unfortunate to pull what is
> essentially a utility function into the Condition variable, so I am
> leaning towards keeping it a module function.

I'm not sure I see the point. It's an operation on a Condition variable,
so it's natural to have it as a Condition method. A module function
would feel rather weird.
History
Date User Action Args
2010-11-02 11:29:05pitrousetrecipients: + pitrou, georg.brandl, kristjan.jonsson, jyasskin
2010-11-02 11:29:03pitroulinkissue10260 messages
2010-11-02 11:29:02pitroucreate