Message113524
- Using _UNSET & similar in the docs is not good; there used to be a
way to note a parameter as optional. Not sure whether there is any
more.
- Docs for methods which take vars/default should include a note
indicating where to find the explanation, since reference docs are
often read in a non-linear manner.
- This is a tortured way to only do something in a particular condition:
value = str(value) if value is not None else None
These two lines are actually more readable, since it's clear that
the branch is a no-op:
if value is not None:
value = str(value)
- _unify_boolean is a strange name; doesn't parallel _unify_values at
all.
- Having _COMPATIBLE and _UNSET defined in the classes looks more
painful than not; no need to change for this patch. (Should be
changed in some later cleanup.) Moving the whole _unify_boolean /
_boolean_states mess to a separate top-level function that can be
used for the conversion is attractive. |
|
Date |
User |
Action |
Args |
2010-08-10 11:15:45 | fdrake | set | recipients:
+ fdrake, georg.brandl, pitrou, michael.foord, lukasz.langa |
2010-08-10 11:15:44 | fdrake | set | messageid: <1281438944.82.0.450024833619.issue9421@psf.upfronthosting.co.za> |
2010-08-10 11:15:42 | fdrake | link | issue9421 messages |
2010-08-10 11:15:41 | fdrake | create | |
|