This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Author jyasskin
Recipients jyasskin, kristjan.jonsson, pitrou
Date 2010-05-24.17:43:37
SpamBayes Score 0.07015652
Marked as misclassified No
Message-id <>
In this case, "acquire" isn't ambiguous. All the other lock types actually acquire a write lock, so it makes sense to have the operation with the same name they use also acquire a write lock on this object.

I realized that read/write locks are actually shared/exclusive locks, which might form the basis for a name that doesn't collide with RLock. Boost ( uses shared_mutex for the concept, so SLock or SELock? There are some algorithms that write while the lock is acquired non-exclusive, so "shared" is actually a better name for the concept, even though posix and Java used read/write.

The possibility of lock downgrading (turning an exclusive lock into a shared lock, without allowing any other exclusive acquisitions in the mean time) might inform your decision about how to name "unlock".
Date User Action Args
2010-05-24 17:43:39jyasskinsetrecipients: + jyasskin, pitrou, kristjan.jonsson
2010-05-24 17:43:39jyasskinsetmessageid: <>
2010-05-24 17:43:38jyasskinlinkissue8800 messages
2010-05-24 17:43:37jyasskincreate