This issue tracker has been migrated to GitHub, and is currently read-only.
For more information, see the GitHub FAQs in the Python's Developer Guide.

Title: Idle doesn't launch
Type: behavior Stage:
Components: IDLE, Installation Versions: Python 2.7
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: Stephan.Bellegy, loewis, roger.serwy
Priority: normal Keywords:

Created on 2010-09-23 13:46 by Stephan.Bellegy, last changed 2022-04-11 14:57 by admin. This issue is now closed.

Messages (6)
msg117184 - (view) Author: Stephan Bellegy (Stephan.Bellegy) Date: 2010-09-23 13:46
Environment is Win7, 32bits. User has Admin rights.

I haven't coded in Python at the office for a while and had a little script to write. Thus, I decided to upgrade from 2.6 to 2.7 (that is : 2.6 was already there and functionnal as far as I remind it and was the first install of Python on the new PC)

2.7 installation run without problems nor warnings, as usual.
But then Idle didn't launch. No message. No Python process running in the background. So I launched it via a shell and grabbed an error message :
IOError: [Errno 13] Permission denied: 'C:\\Users\\Foobar\\.idlerc\\recent-files.lst'

Then I googled and found

Deleting ~\.idlerc\ did the trick and now Idle runs fine.

So the bug 1743 isn't clearly solved and this is what I suspect :
My Windows is localized in French. From the DOS Shell, the User Dir is C:\Users\FOOBAR
but Windows Explorer displays in its address bar : C:\Utilisateurs\FOOBAR
Maybe the problem comes from here ?
msg117193 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2010-09-23 14:39
Is that problem reproducible?

I.e. what did you do, in what order, and: when you do it again, will the problem occur again?
msg117204 - (view) Author: Stephan Bellegy (Stephan.Bellegy) Date: 2010-09-23 16:08
it is reproductible.
At first, Python 2.6.? was installed.

i tried to install 2.7 and got the problem
uninstalled 2.7
tried 2.6.6 and got the problem

then google, delete dir and got it running
msg150073 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2011-12-22 07:04
This bug looks almost identical to issue4625 which was fixed. The only difference is the French localization aspect.
msg158289 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2012-04-14 22:06
Is this still a valid issue?
msg159823 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2012-05-02 23:44
Closing this issue as a duplicate of #4625.
Date User Action Args
2022-04-11 14:57:06adminsetgithub: 54134
2012-05-02 23:44:01roger.serwysetstatus: pending -> closed
resolution: duplicate
messages: + msg159823
2012-04-14 22:06:37roger.serwysetstatus: open -> pending
type: behavior
messages: + msg158289
2011-12-22 07:04:49roger.serwysetnosy: + roger.serwy
messages: + msg150073
2010-09-24 21:26:43terry.reedysetversions: - Python 2.6
2010-09-23 16:08:14Stephan.Bellegysetmessages: + msg117204
2010-09-23 14:39:08loewissetnosy: + loewis
messages: + msg117193
2010-09-23 13:46:12Stephan.Bellegycreate