classification
Title: Crashes upon run after syntax error encountered in OSX 10.5.8
Type: crash Stage: resolved
Components: IDLE Versions: Python 3.1, Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder: OS X IDLE 3 with Tk 8.4 appears to hang with syntax error
View: 11053
Assigned To: ned.deily Nosy List: brian89, ned.deily, r.david.murray, ronaldoussoren, william.barr
Priority: normal Keywords:

Created on 2010-09-03 19:42 by william.barr, last changed 2011-01-29 23:45 by ned.deily. This issue is now closed.

Messages (6)
msg115491 - (view) Author: William Barr (william.barr) Date: 2010-09-03 19:42
Steps for reproduction:
1.  Open a new code window
2.  Enter python code which contains a syntax error
3.  F5 and attempt to run the file (This was done without saving first)
4.  Close the syntax error dialog.  
5.  Fix the syntax error and try to F5 again without saving again.  
6.  IDLE will encounter an error and unexpectedly close.  

I'm reporting this after having tested this on 4 different OSX 10.5.8 machines.  I'm not sure if other versions of Python are also susceptible to this as well.
msg115539 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2010-09-03 23:16
Following your test case, I am able to produce a deadlocked IDLE when using the python.org 3.1.2 OS X installer on 10.5.8 when using just the Apple-supplied Tk 8.4 framework.  After installing a recent ActiveState Tcl/Tk 8.4 framework (the python.org installers are built to dynamically link with either), the hang is no longer reproducible.  There doesn't seem to be a problem with either 2.6.6 or 2.7, with either version of Tcl/Tk, nor is there on 10.6 but the Apple-supplied 8.4 there is much newer than that in 10.5. I'm doing some more triage work on this issue with 3.1 and 3.2.

In the interim, a workaround may be to install the ActiveState Tcl/Tk 8.4 on your systems if that is acceptable.
msg115720 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2010-09-06 17:11
IDLE from the Python 3.2a2 OS X installer exhibits the same buggy behavior on 10.5 as 3.1.2 (hangs with system Tk 8.4, OK with ActiveState Tk 8.4).  There also seem to be some unexpected differences in IDLE behavior between 2.7 and 3.x as if some changes were not backported.  Will triage further.
msg115751 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-09-07 11:32
If this is a problem with the Apple supplied tk there isn't much we can do about it from the Python end.  We've had a number of other bugs like that...
msg122550 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2010-11-27 20:34
Adding the nosy list from Issue6628 where this problem was originally reported.  What's interesting about this is that IDLE 2.x does not exhibit this behavior, AFAICT, when using the same Apple Tk 8.4.  As there are other odd behaviors with IDLE 3.x on OS X, I want to investigate this further.
msg127499 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2011-01-29 23:45
The problem was caused by a minor change in IDLE during the port of IDLE from 2.x to 3.x.  It is fixed by the changes for Issue11053: r88234 (3.2rc2) and r88242 (planned for 3.1.4).
History
Date User Action Args
2011-03-09 05:40:59ned.deilyunlinkissue10690 superseder
2011-01-29 23:47:34ned.deilyunlinkissue6628 superseder
2011-01-29 23:45:41ned.deilysetstatus: open -> closed
nosy: ronaldoussoren, ned.deily, r.david.murray, brian89, william.barr
messages: + msg127499

superseder: OS X IDLE 3 with Tk 8.4 appears to hang with syntax error
resolution: duplicate
stage: resolved
2010-12-16 19:04:07ned.deilylinkissue10718 superseder
2010-12-13 17:52:54ned.deilylinkissue10690 superseder
2010-11-27 20:34:45ned.deilylinkissue6628 superseder
2010-11-27 20:34:33ned.deilysetnosy: + ronaldoussoren, brian89
messages: + msg122550
2010-09-07 11:32:44r.david.murraysetnosy: + r.david.murray
messages: + msg115751
2010-09-06 17:12:01ned.deilysetmessages: - msg115719
2010-09-06 17:11:47ned.deilysetassignee: ned.deily
messages: + msg115720
2010-09-06 17:09:44ned.deilysetmessages: + msg115719
versions: + Python 3.2
2010-09-03 23:16:01ned.deilysetnosy: + ned.deily
messages: + msg115539
2010-09-03 19:42:52william.barrcreate