classification
Title: Python 2.7 IDLE fails on OS X 10.6
Type: Stage:
Components: IDLE, macOS Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: can't import Tkinter / use IDLE after installing Python 2.7 on Mac OS X
View: 9227
Assigned To: ronaldoussoren Nosy List: Alex.Rodriguez, bpumali, ned.deily, ronaldoussoren, terry.reedy
Priority: normal Keywords:

Created on 2010-08-16 07:20 by bpumali, last changed 2010-11-29 19:30 by terry.reedy. This issue is now closed.

Messages (7)
msg114039 - (view) Author: beng umali (bpumali) Date: 2010-08-16 07:27
I can't seem to get my head around solving this problem after installing Python 2.7 on a mac os x 10.6.4. The error message that comes out after clicking IDLE from the applications reads:

"IDLE's subprocess didn't make connection. Either IDLE can't start a subprocess or personal firewall software is blocking the connection."

Appreciate any help.

Cheers!
msg114096 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2010-08-17 02:53
This is a duplicate of open Issue9227.  As described there, a workaround is to use the 32-bit only ("10.3") python.org installer for Python 2.7.
msg114434 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2010-08-20 17:46
Ned, any reason not to close this as a duplicate, with #9227 as superseder?
msg114435 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2010-08-20 17:55
Terry, go ahead, I think that's the proper resolution.
msg114469 - (view) Author: beng umali (bpumali) Date: 2010-08-21 00:10
apologies for the late reply. issue now resolved. thank you.
msg122853 - (view) Author: Alex Rodriguez (Alex.Rodriguez) Date: 2010-11-29 19:18
I didn't see this issue resolved in the changelog for 2.7.1 release. Are we going to wait until 2.7.2 now??
msg122854 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2010-11-29 19:30
This issue was closed as a duplicate of #9227.
Please direct further comments there.
In any case, all issues wait until a person with the requisite knowledge volunteers a fix and a core developer commits the fix.
History
Date User Action Args
2010-11-29 19:30:33terry.reedysetmessages: + msg122854
2010-11-29 19:18:47Alex.Rodriguezsetnosy: + Alex.Rodriguez
messages: + msg122853
2010-08-21 00:10:28bpumalisetmessages: + msg114469
2010-08-20 20:12:33terry.reedysetstatus: open -> closed
resolution: duplicate
superseder: can't import Tkinter / use IDLE after installing Python 2.7 on Mac OS X
2010-08-20 17:55:01ned.deilysetmessages: + msg114435
2010-08-20 17:46:11terry.reedysetnosy: + terry.reedy
messages: + msg114434
2010-08-17 02:53:50ned.deilysettitle: IDLE subprocess error -> Python 2.7 IDLE fails on OS X 10.6
nosy: + ronaldoussoren, ned.deily

messages: + msg114096

assignee: ronaldoussoren
components: + macOS
2010-08-16 07:27:48bpumalisetversions: + Python 2.7
messages: + msg114039
components: + IDLE
title: IDLE -> IDLE subprocess error
2010-08-16 07:20:16bpumalicreate