classification
Title: IDLE won't launch on XP
Type: behavior Stage: resolved
Components: IDLE Versions: Python 3.2, Python 3.3, Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder: IDLE won't open anymore, .idlerc unaccessible
View: 4625
Assigned To: Nosy List: Chris.Leaf, loewis, ned.deily, roger.serwy, rugburnpy
Priority: normal Keywords:

Created on 2010-07-28 21:27 by Chris.Leaf, last changed 2011-12-14 08:21 by ned.deily. This issue is now closed.

Files
File name Uploaded Description Edit
Attributes.JPG Chris.Leaf, 2010-07-28 21:53 Attributes of the Folder
Messages (18)
msg111850 - (view) Author: Chris Leaf (Chris.Leaf) Date: 2010-07-28 21:27
I have been using IDLE on my previous laptop and it was working well although I have to say I'm still very new to python. I've read around about the issue and can't find any solution I can use. I can run the IDLE GUI through the python command line version by saying "import idle" but it generates a bunch of error lines (copied the command prompt):

>>> import idle
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "c:\python31\lib\idlelib\idle.py", line 11, in <module>
    idlelib.PyShell.main()
  File "c:\python31\lib\idlelib\PyShell.py", line 1388, in main
    shell = flist.open_shell()
  File "c:\python31\lib\idlelib\PyShell.py", line 277, in open_shell
    self.pyshell = PyShell(self)
  File "c:\python31\lib\idlelib\PyShell.py", line 813, in __init__
    OutputWindow.__init__(self, flist, None, None)
  File "c:\python31\lib\idlelib\OutputWindow.py", line 16, in __init__
    EditorWindow.__init__(self, *args)
  File "c:\python31\lib\idlelib\EditorWindow.py", line 261, in __init__
    self.update_recent_files_list()
  File "c:\python31\lib\idlelib\EditorWindow.py", line 779, in update_recent_fil
es_list
    rf_file = open(self.recent_files_path, 'w')
IOError: [Errno 13] Permission denied: 'C:\\Documents and Settings\\<USERNAME>\\.idle
rc\\recent-files.lst'


I have tried to use Explorer to reach the files and I get a permission error (the same occurs when trying to reach with the command prompt). I have tried to change the read only nature of this folder and it automatically reverts after the attribute is set. Also the folder is empty according to explorer. I have tried running it with my firewall disabled. 

I am running 32bit XP on a lenovo T510 with 3.1.2 python installed

Thanks in advance!
msg111853 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2010-07-28 21:39
> I have tried to use Explorer to reach the files and I get a
> permission error (the same occurs when trying to reach with the
> command prompt). I have tried to change the read only nature of this
> folder and it automatically reverts after the attribute is set. Also
> the folder is empty according to explorer. I have tried running it
> with my firewall disabled.

As a work-around, remove the hidden flag from the idlerc folder and
all of its files.
msg111854 - (view) Author: Chris Leaf (Chris.Leaf) Date: 2010-07-28 21:43
Also the IDLE that I do manage to get open really doesn't work correctly, more errors appear on the command line console as I try to do things like close the IDLE window. So that doesn't serve as a useful tool either
msg111855 - (view) Author: Chris Leaf (Chris.Leaf) Date: 2010-07-28 21:46
I can clear the attributes from the properties window of the folder but if I remove them both it will automatically reset it back to Read Only every time i close the properties window. I can get it to be hidden but I can't make it permanently available.
msg111856 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2010-07-28 21:49
> I can clear the attributes from the properties window of the folder
> but if I remove them both it will automatically reset it back to Read
> Only every time i close the properties window. I can get it to be
> hidden but I can't make it permanently available.

I'm not talking about the read-only attribute. It's alright that you
can't clear it - Windows doesn't support that, and it's not a problem
at all.

I'm talking about the "hidden" attribute.
msg111858 - (view) Author: Chris Leaf (Chris.Leaf) Date: 2010-07-28 21:53
The hidden field is not filled in, here's a screenshot of the attributes options
msg111859 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2010-07-28 22:06
> The hidden field is not filled in, here's a screenshot of the attributes options

Ok. Remove the entire .idlerc folder, then.
msg111860 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2010-07-28 22:08
> Ok. Remove the entire .idlerc folder, then.

Before doing that (if you still can) try something else.

Go *into* the .idlerc folder, and remove the hidden flag
from all individual files.
msg111862 - (view) Author: Chris Leaf (Chris.Leaf) Date: 2010-07-28 22:15
Upon trying to delete I'm prompted with an error:

Access is denied.

Make sure the disc is not full or write-protected and that the file is currently not in use.

My disc isn't full and I cannot find anything accessing it (and the folder is empty so...)

Is there a way around this?
msg111863 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2010-07-28 22:16
The folder is not empty. Configure Explorer so that it displays hidden files.
msg111864 - (view) Author: Chris Leaf (Chris.Leaf) Date: 2010-07-28 22:16
I also cannot get into the folder itself.

"Access Denied"
msg111869 - (view) Author: Chris Leaf (Chris.Leaf) Date: 2010-07-28 23:02
The problem is that I can do nothing to the folder at all
msg111940 - (view) Author: Chris Leaf (Chris.Leaf) Date: 2010-07-29 14:40
Sorry but I still cannot get it to work because the folder remains inaccessible to me and immutable. Is there any way around this problem?
msg111973 - (view) Author: Chris Leaf (Chris.Leaf) Date: 2010-07-29 17:14
I solved the problem myself by editing the EditorWindow.py file where it sets self.recent_files_path by setting it to a different file location (I created a file in my Python31 directory named recent-files.lst and then set the recent_files_path to the absolute path to this file I made). This seems to be working so far and works like a complete work around the .idlerc folder issue. Will report if this doesn't work out later
msg111977 - (view) Author: Martin v. Löwis (loewis) * (Python committer) Date: 2010-07-29 17:24
Sorry, I'm busy with other stuff and won't be able to look into this for another week or so.
msg122253 - (view) Author: demarcus (rugburnpy) Date: 2010-11-24 00:20
Had this issue.. figured out what's causing it... definitively.

I had an earlier version of python installed, and I created a pythonhome user variable: "c:\python24."

I'm now using Python 2.5, and that old variable was:
1.) Keeping me from opening the IDLE
2.) Keeping the console from finding the os module.  This is also the source of the import os error.

TO FIX:
- modify the pythonhome variable to your current version, or.. remove it.

-Dmark
www.dmarkphotography.com
msg149418 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2011-12-14 02:52
This is a duplicate of #4625.
msg149430 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2011-12-14 08:21
As there are proposed patches in Issue4625 that address the original problem reported here, let's move the discussion there.
History
Date User Action Args
2011-12-14 08:21:40ned.deilysetstatus: open -> closed

superseder: IDLE won't open anymore, .idlerc unaccessible
versions: + Python 2.7, Python 3.2, Python 3.3
nosy: + ned.deily

messages: + msg149430
resolution: duplicate
stage: resolved
2011-12-14 02:52:32roger.serwysetnosy: + roger.serwy
messages: + msg149418
2010-11-24 00:20:07rugburnpysetnosy: + rugburnpy

messages: + msg122253
versions: - Python 3.1
2010-07-29 17:24:46loewissetmessages: + msg111977
2010-07-29 17:14:12Chris.Leafsetmessages: + msg111973
2010-07-29 14:40:38Chris.Leafsetmessages: + msg111940
2010-07-28 23:02:25Chris.Leafsetmessages: + msg111869
2010-07-28 22:16:17Chris.Leafsetmessages: + msg111864
2010-07-28 22:16:02loewissetmessages: + msg111863
2010-07-28 22:15:18Chris.Leafsetmessages: + msg111862
2010-07-28 22:08:08loewissetmessages: + msg111860
2010-07-28 22:06:39loewissetmessages: + msg111859
2010-07-28 21:53:57Chris.Leafsetfiles: + Attributes.JPG

messages: + msg111858
2010-07-28 21:49:30loewissetmessages: + msg111856
2010-07-28 21:46:45Chris.Leafsetmessages: + msg111855
2010-07-28 21:43:32Chris.Leafsetmessages: + msg111854
2010-07-28 21:39:24loewissetnosy: + loewis
messages: + msg111853
2010-07-28 21:27:59Chris.Leafcreate