classification
Title: Add reader redirect from test package docs to unittest module
Type: Stage: needs patch
Components: Documentation Versions: Python 3.2, Python 2.7
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, dstanek, ncoghlan, sandro.tosi
Priority: normal Keywords: easy

Created on 2010-07-24 10:49 by ncoghlan, last changed 2011-01-01 00:59 by ncoghlan. This issue is now closed.

Messages (3)
msg111450 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2010-07-24 10:49
Brett updated the docs for the test package to (correctly) point out that it is our internal testing package and isn't subject to the same stringent backwards compatibility rules as the rest of the standard library.

A "see also" link pointing readers that have landed there over to the unittest module for their testing infrastructure needs would be a friendly thing to include.
msg124970 - (view) Author: Sandro Tosi (sandro.tosi) * (Python committer) Date: 2010-12-31 17:44
Hi Nick,
the "See also" section already points to unittest module; are you asking to extend its description to mention that's the tool people should use for their unittest suites?

Cheers,
Sandro
msg124985 - (view) Author: Nick Coghlan (ncoghlan) * (Python committer) Date: 2011-01-01 00:59
Yeah, I think I wrote this issue based on the diff that added the new note at the top, rather than looking at the existing intro text that already references unittest and doctest.

No need to change anything after all.
History
Date User Action Args
2011-01-01 00:59:57ncoghlansetstatus: open -> closed

messages: + msg124985
resolution: not a bug
nosy: ncoghlan, dstanek, sandro.tosi, docs@python
2010-12-31 17:44:44sandro.tosisetnosy: + sandro.tosi
messages: + msg124970
2010-07-31 18:24:44dstaneksetnosy: + dstanek
2010-07-24 10:49:05ncoghlancreate