classification
Title: c/profile Profile class is not documented
Type: Stage: needs patch
Components: Documentation Versions: Python 3.1, Python 3.2, Python 2.7, Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: docs@python Nosy List: docs@python, giampaolo.rodola, ysj.ray
Priority: normal Keywords:

Created on 2010-07-19 08:59 by giampaolo.rodola, last changed 2010-07-19 11:37 by giampaolo.rodola. This issue is now closed.

Messages (3)
msg110722 - (view) Author: Giampaolo Rodola' (giampaolo.rodola) * (Python committer) Date: 2010-07-19 08:59
http://docs.python.org/library/profile.html

...while it is, for example, for hotshot module:
http://docs.python.org/library/hotshot.html#hotshot.Profile

Profile class contains some useful methods which are surely worth mentioning, like print_stat() and runcall() above all.
msg110726 - (view) Author: ysj.ray (ysj.ray) Date: 2010-07-19 10:10
I guess this is intended not documented:

http://docs.python.org/dev/py3k/library/profile.html#extensions-deriving-better-profilers

Here it said:
"The Profile class of both modules, profile and cProfile, were written so that derived classes could be developed to extend the profiler. The details are not described here, as doing this successfully requires an expert understanding of how the Profile class works internally. Study the source code of the module carefully if you want to pursue this."

These sentences guide reader to read the source code.
msg110736 - (view) Author: Giampaolo Rodola' (giampaolo.rodola) * (Python committer) Date: 2010-07-19 11:37
Oh right, I didn't notice that.
Closing this out as invalid.
History
Date User Action Args
2010-07-19 11:37:03giampaolo.rodolasetstatus: open -> closed
resolution: not a bug
messages: + msg110736
2010-07-19 10:10:58ysj.raysetnosy: + ysj.ray
messages: + msg110726
2010-07-19 08:59:57giampaolo.rodolacreate