classification
Title: IDLE: raises Exception TclError in a special case
Type: Stage: resolved
Components: Tkinter Versions: Python 3.1, Python 3.2, Python 2.7, Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: python3 closes + home keys
View: 4676
Assigned To: Nosy List: doko, ned.deily, roger.serwy
Priority: normal Keywords:

Created on 2010-07-08 14:40 by doko, last changed 2012-01-04 02:51 by ned.deily. This issue is now closed.

Messages (3)
msg109544 - (view) Author: Matthias Klose (doko) * (Python committer) Date: 2010-07-08 14:40
[forwarded from https://launchpad.net/bugs/597763]

seen with all version, built with Tcl8.5

To reproduce the bug, use the following class:

class x(object):
 TEST = "hello"
 THE_MAXIMUM = 55

 def __init__(self, a, b):
  self.a = 3
  self.b = "test"

and set the cursor behind "test". After that use SHIFT + UP (so from 3 to incl. "test" will be marked) and after that use SHIFT + POS1, which will produce this exception:

>>> Exception in Tkinter callback
Traceback (most recent call last):
  File "/usr/lib/python2.6/lib-tk/Tkinter.py", line 1413, in __call__
    return self.func(*args)
  File "/usr/lib/python2.6/idlelib/MultiCall.py", line 151, in handler
    r = l[i](event)
  File "/usr/lib/python2.6/idlelib/EditorWindow.py", line 335, in home_callback
    if self.text.compare(first,">",last):
  File "/usr/lib/python2.6/lib-tk/Tkinter.py", line 2863, in compare
    self._w, 'compare', index1, op, index2))
TclError: expected boolean value but got ""
msg150054 - (view) Author: Roger Serwy (roger.serwy) * (Python committer) Date: 2011-12-21 23:53
This issue was fixed in 500e48708470, as part of issue3851.
msg150575 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2012-01-04 02:51
The problem was originally reported in Issue4676 and fixed partly there and partly in Issue3851.
History
Date User Action Args
2012-01-04 02:51:01ned.deilysetstatus: open -> closed

superseder: python3 closes + home keys

nosy: + ned.deily
messages: + msg150575
resolution: duplicate
stage: resolved
2011-12-21 23:53:20roger.serwysetnosy: + roger.serwy
messages: + msg150054
2010-07-08 14:40:13dokocreate