classification
Title: email.encoders.encode_base64 sets payload to bytes, should set to str
Type: Stage: resolved
Components: Library (Lib) Versions: Python 3.1, Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder: email.generator.Generator object bytes/str crash - b64encode() bug?
View: 4768
Assigned To: r.david.murray Nosy List: forest_atq, l0nwlf, r.david.murray
Priority: normal Keywords: patch

Created on 2010-06-04 14:07 by forest_atq, last changed 2010-06-26 08:25 by eric.araujo. This issue is now closed.

Files
File name Uploaded Description Edit
python-email-encoders-base64-str.patch forest_atq, 2010-06-04 14:07 Patch to fix issue
Messages (3)
msg107055 - (view) Author: Forest Bond (forest_atq) * Date: 2010-06-04 14:07
Ran into this while tackling issue3244.  Encoded payload members should not be bytes.  In the case of base64, we should have an ascii string.
msg107062 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-06-04 14:57
This is a duplicate of issue 4768.  Could you attach your patch to that issue, please?
msg107064 - (view) Author: Forest Bond (forest_atq) * Date: 2010-06-04 15:02
Duplicate.  See issue4768.
History
Date User Action Args
2010-06-26 08:25:19eric.araujosetresolution: duplicate
stage: resolved
2010-06-04 15:02:17forest_atqsetstatus: open -> closed

messages: + msg107064
2010-06-04 14:57:37r.david.murraysetassignee: r.david.murray
superseder: email.generator.Generator object bytes/str crash - b64encode() bug?
messages: + msg107062
2010-06-04 14:13:24eric.araujosetnosy: + r.david.murray, l0nwlf

versions: - Python 3.3
2010-06-04 14:07:17forest_atqcreate