classification
Title: --user-access-control=force produces invalid installer on Vista
Type: crash Stage:
Components: Distutils Versions: Python 2.7, Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder: friendly errors for UAC misbehavior in windows installers
View: 8908
Assigned To: tarek Nosy List: koen, mhammond, tarek, techtonik
Priority: normal Keywords:

Created on 2010-06-01 18:37 by techtonik, last changed 2010-06-11 02:21 by r.david.murray. This issue is now closed.

Files
File name Uploaded Description Edit
wget-0.6.win32.exe techtonik, 2010-06-01 22:54 --user-access-control=force
Messages (9)
msg106852 - (view) Author: anatoly techtonik (techtonik) Date: 2010-06-01 18:37
Running `python setup.py bdist_wininst --user-access-control=force` produces invalid installer that fails to install with the error message:

Failed to start elevated process (ShellExecute returned 5)
msg106856 - (view) Author: anatoly techtonik (techtonik) Date: 2010-06-01 20:11
See also issue8871 and original report http://scons.tigris.org/issues/show_bug.cgi?id=2533
msg106859 - (view) Author: Mark Hammond (mhammond) * (Python committer) Date: 2010-06-01 20:30
Is it possible the installer is being run from a network share?  A comment from PC/bdist_wininst/install.c:

	// interesting failure scenario that has been seen: initial executable
	// runs from a network drive - but once elevated, that network share
	// isn't seen, and ShellExecute fails with SE_ERR_ACCESSDENIED.

SE_ERR_ACCESSDENIED is 5, so googling for that might offer more insights.
msg106864 - (view) Author: anatoly techtonik (techtonik) Date: 2010-06-01 22:52
It is local Ext2 partition system accessible through http://www.fs-driver.org/ on the same HDD as primary system partition. But there is definitely issue with difference between drives.

There is no problem if the package is executed from the NTFS system drive - permissions asked as expected, no errors. On the Ext2 partition VLC and other installers that require elevated privileges fail. I do not remember any such problems last year, but it just can be that most applications on this drive are not windows specific or do not require elevated privileges.

I still doesn't explain why this drive is threatened as "network". It would be nice to see how Windows treats other partition types - FAT32 or FAT16.
msg106865 - (view) Author: anatoly techtonik (techtonik) Date: 2010-06-01 22:54
Attaching installer file for testing.
msg106868 - (view) Author: Koen van de Sande (koen) Date: 2010-06-01 23:43
This is listed as a known limitation of the Ext2 FS driver. From http://www.fs-driver.org/relnotes.html :

===
Running programs on an Ext2/Ext3 volume on Windows Vista 

Currently it is not possible to start a program on Vista if UAC is enabled and the program's executable is stored on an Ex2/Ext3 volume. An "invalid parameter" message box appears, but the program does not start. 

UAC is the feature of Vista that prompts the user to elevate the user privileges to administrator level when necessary. UAC is enabled by default. It is not recommended to disable it. 

The problem is caused by Vista's internals: There is some code that compares whether the name of the file system type is one of the following: "NTFS", "FAT", "FAT32", "CDFS", "NPFS", "MSFS" or "UDF". If there is a match, it is one of Microsoft's file system types and a lot of code is skipped in the Multiple UNC Provider (MUP) implementation of Vista. If the file system type is a third-party type, for example "Ext2", some code runs in the MUP of Vista that always generates an ERROR_INVALID_PARAMETER error status code due to a bug of Vista.
===

So the bug is in that FS (or in Windows if you will). It is not something Python can fix.
msg106895 - (view) Author: anatoly techtonik (techtonik) Date: 2010-06-02 16:42
Thanks for thorough explanation. Can somebody close it with some resolution like "Can't fix. OS level problem"?
msg106910 - (view) Author: anatoly techtonik (techtonik) Date: 2010-06-02 20:30
Is it possible to detect this situation and display more user-friendly error message with a reference to this issue?
msg107161 - (view) Author: anatoly techtonik (techtonik) Date: 2010-06-05 19:42
Please add issue8908 as superseder.
History
Date User Action Args
2010-06-11 02:21:48r.david.murraysetsuperseder: friendly errors for UAC misbehavior in windows installers
2010-06-05 19:42:06techtoniksetmessages: + msg107161
2010-06-02 20:30:56techtoniksetmessages: + msg106910
2010-06-02 19:51:26eric.araujosetstatus: open -> closed
resolution: not a bug
2010-06-02 16:42:50techtoniksetmessages: + msg106895
2010-06-01 23:43:38koensetnosy: + koen
messages: + msg106868
2010-06-01 22:54:05techtoniksetfiles: + wget-0.6.win32.exe

messages: + msg106865
2010-06-01 22:52:36techtoniksetmessages: + msg106864
2010-06-01 20:30:46mhammondsetnosy: + mhammond
messages: + msg106859
2010-06-01 20:11:02techtoniksetmessages: + msg106856
2010-06-01 18:37:59techtonikcreate