classification
Title: idle crash UnicodeDecodeError utf-8 codec
Type: crash Stage:
Components: IDLE Versions: Python 3.1
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Tkinter binding involving Control-spacebar raises unicode error
View: 1028
Assigned To: Nosy List: andyharrington
Priority: normal Keywords:

Created on 2010-05-18 18:21 by andyharrington, last changed 2010-10-28 08:21 by ned.deily. This issue is now closed.

Messages (2)
msg105996 - (view) Author: Andy Harrington (andyharrington) Date: 2010-05-18 18:21
I was editing in idle in python 3.1, typing away.  I had been doing it for hours.  I do not think I had jumped to the shell window.  Suddenly idle crashed, with this error message in the the  ubuntu 9,10 terminal window:

Traceback (most recent call last):
  File "/usr/bin/idle3", line 5, in <module>
    main()
  File "/usr/lib/python3.1/idlelib/PyShell.py", line 1420, in main
    root.mainloop()
  File "/usr/lib/python3.1/tkinter/__init__.py", line 1012, in mainloop
    self.tk.mainloop(n)
UnicodeDecodeError: 'utf8' codec can't decode bytes in position 0-1: illegal encoding

I do not know what key combination I had just typed.  I may have just hit a crtl or alt combination.

The hardware is an Acer notebook.

This is certainly an exception that should be caught!  I did not get to even save my work.
msg119764 - (view) Author: Ned Deily (ned.deily) * (Python committer) Date: 2010-10-28 08:21
Duplicate of Issue1028.
History
Date User Action Args
2010-10-28 08:21:56ned.deilysetstatus: open -> closed
nosy: - ned.deily
2010-10-28 08:21:15ned.deilysetnosy: + ned.deily
messages: + msg119764
resolution: duplicate

superseder: Tkinter binding involving Control-spacebar raises unicode error
2010-05-18 18:21:51andyharringtoncreate