classification
Title: Subprocess.py broken in trunk
Type: Stage:
Components: Versions: Python 2.7
process
Status: closed Resolution: duplicate
Dependencies: Superseder:
Assigned To: Nosy List: pakal, vstinner
Priority: normal Keywords: patch

Created on 2010-05-14 18:34 by pakal, last changed 2010-05-14 21:58 by vstinner. This issue is now closed.

Files
File name Uploaded Description Edit
broken_subprocess.patch pakal, 2010-05-14 18:34
Messages (3)
msg105736 - (view) Author: Pascal Chambon (pakal) * Date: 2010-05-14 18:34
There seems to have been some broken commit on subprocess.py in trunk - the moduel can't be imported due to unexisting argument defaults.

Here is a very quick patch, but more inquiry migh tbe necessary to find out what happened.
msg105737 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2010-05-14 18:36
The regression was introduced by r81154: issue #5099.
msg105772 - (view) Author: STINNER Victor (vstinner) * (Python committer) Date: 2010-05-14 21:58
Thank you for your patch: I closed #5099 regression.
History
Date User Action Args
2010-05-14 21:58:48vstinnersetstatus: open -> closed
resolution: duplicate
messages: + msg105772
2010-05-14 18:36:40vstinnersetnosy: + vstinner
messages: + msg105737
2010-05-14 18:34:34pakalcreate