classification
Title: tarfile: first character of member names doubled
Type: Stage:
Components: Library (Lib) Versions: Python 2.6
process
Status: closed Resolution:
Dependencies: Superseder:
Assigned To: lars.gustaebel Nosy List: lars.gustaebel, pooryorick
Priority: normal Keywords:

Created on 2010-05-12 21:19 by pooryorick, last changed 2010-05-13 18:06 by pooryorick. This issue is now closed.

Messages (3)
msg105609 - (view) Author: Poor Yorick (pooryorick) * Date: 2010-05-12 21:19
In the following file, for python 2.6.4, tarfile.list doubles the first character of each member name:

http://watson.nci.nih.gov/cran_mirror/src/contrib/Archive/time/time_1.0.tar.gz

gnu tar handles the file correctly
msg105626 - (view) Author: Lars Gustäbel (lars.gustaebel) * (Python committer) Date: 2010-05-13 07:36
Unfortunately, I cannot reproduce your problem and ask you to please provide more information. Would it be possible to attach the output or a screenshot depicting the problem? Which operating system/distribution do you use? Have you double-checked your testing conditions?
msg105649 - (view) Author: Poor Yorick (pooryorick) * Date: 2010-05-13 18:06
I can't reproduce it now, either.
History
Date User Action Args
2010-05-13 18:06:02pooryoricksetstatus: open -> closed

messages: + msg105649
2010-05-13 07:36:16lars.gustaebelsetmessages: + msg105626
2010-05-13 07:04:31lars.gustaebelsetassignee: lars.gustaebel

nosy: + lars.gustaebel
2010-05-12 21:19:37pooryorickcreate