classification
Title: Support RFC 6531 in smptlib
Type: enhancement Stage: resolved
Components: email, Library (Lib) Versions: Python 3.5
process
Status: closed Resolution: duplicate
Dependencies: Superseder: RFC 6531 (SMTPUTF8) support in smtplib
View: 22027
Assigned To: Nosy List: barry, christian.heimes, dlam, exarkun, ezio.melotti, hhallman, iElectric, moijes12, r.david.murray
Priority: normal Keywords: easy, patch

Created on 2010-04-21 19:17 by iElectric, last changed 2015-05-16 19:51 by r.david.murray. This issue is now closed.

Files
File name Uploaded Description Edit
issue8489.patch hhallman, 2013-02-23 16:58
Messages (9)
msg103890 - (view) Author: Domen Kožar (iElectric) Date: 2010-04-21 19:17
Module smtplib, line 574, in login
  Module smtplib, line 538, in encode_cram_md5
  Module hmac, line 72, in __init__
TypeError: character mapping must return integer, None or unicode

Following traceback occurs when doing connection.login(u'foobar@domain.com', 'justdoit') to issue an ESMTP.

Python 2.6.4 (r264:75706, Mar 11 2010, 18:33:18)
msg103893 - (view) Author: Jean-Paul Calderone (exarkun) * (Python committer) Date: 2010-04-21 19:24
SMTP (RFC 2821) doesn't support non-ASCII envelope addresses.  A better behavior here would be for connection.login to raise a ValueError or a TypeError whenever a non-str is passed in.

RFC 5336, though, adds the UTF8SMTP extension, which adds support for UTF-8 encoded unicode mailboxes.  If the server advertises the UTF8SMTP capability, then smtplib could encode unicode using UTF-8 and pass it on.

This is really a feature request (RFC 5336 support), not a bug.
msg103901 - (view) Author: Domen Kožar (iElectric) Date: 2010-04-21 19:56
Plone currently just passes unicode data around, maybe additional documentation note will do for avoiding such trobules.

Thanks for quick response.
msg172266 - (view) Author: Christian Heimes (christian.heimes) * (Python committer) Date: 2012-10-06 23:41
I've changed the topic and set the version to 3.4.
msg172278 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2012-10-07 01:18
Woops, did not mean to close the issue.
msg182763 - (view) Author: Hugo Hallman (hhallman) * Date: 2013-02-23 16:58
Can not reproduce the problem in 2.7
Attaching a patch with test cases proving that the problem is solved.
Patch based on current tip 2.7.
msg182772 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2013-02-23 17:14
Well, this issue changed into a feature request for UTF8SMTP support, which I do intend to implement at some point.  

It does indeed appear like the original problem (not converting unicode strings into ASCII) was fixed in 2.7 at some point, though, which is good news, thanks.
msg182808 - (view) Author: David Lam (dlam) * Date: 2013-02-23 20:02
looks like RFC 6531 obsoletes 5336  -->   http://datatracker.ietf.org/doc/rfc6531/

(6531 says its the "Proposed Standard", whereas 5336 says its "Experimental" etc etc)
msg182825 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2013-02-23 21:52
Thanks for the pointer.  I keep reading "SMTPUTF8" as "SMTPUFF", but otherwise at a quick glance it looks like an improvement.
History
Date User Action Args
2015-05-16 19:51:23r.david.murraysetstatus: open -> closed
superseder: RFC 6531 (SMTPUTF8) support in smtplib
stage: needs patch -> resolved
resolution: duplicate
versions: + Python 3.5, - Python 3.4
2014-07-27 10:23:24moijes12setnosy: + moijes12
2013-12-28 17:17:31r.david.murraylinkissue20084 superseder
2013-02-23 21:52:18r.david.murraysetmessages: + msg182825
title: Support UTF8SMTP as part of RFC 5336 in smptlib -> Support RFC 6531 in smptlib
2013-02-23 20:02:49dlamsetmessages: + msg182808
2013-02-23 17:14:43r.david.murraysetmessages: + msg182772
2013-02-23 16:58:31hhallmansetfiles: + issue8489.patch

nosy: + hhallman
messages: + msg182763

keywords: + patch
2013-01-08 09:20:37dlamsetnosy: + dlam
2012-10-07 15:33:43r.david.murraysetcomponents: + email
2012-10-07 12:12:44Ramchandra Aptesetcomponents: - Unicode, email
title: Support UTF8SMTP as part of RFC 5336 in smtlib -> Support UTF8SMTP as part of RFC 5336 in smptlib
2012-10-07 01:18:33r.david.murraysetstatus: closed -> open

messages: + msg172278
title: Support UTF8SMTP as part of RFC 5336 -> Support UTF8SMTP as part of RFC 5336 in smtlib
2012-10-07 01:07:35r.david.murraysetstatus: open -> closed
components: + email
stage: needs patch
2012-10-06 23:45:42pitrousetnosy: + barry, r.david.murray
2012-10-06 23:41:53christian.heimessettype: crash -> enhancement
title: smtplib.SMTP.login() breaks with unicode input -> Support UTF8SMTP as part of RFC 5336
components: + Library (Lib)

keywords: + easy
nosy: + ezio.melotti, christian.heimes
versions: + Python 3.4, - Python 2.6
messages: + msg172266
2010-04-21 19:56:43iElectricsetmessages: + msg103901
2010-04-21 19:24:19exarkunsetnosy: + exarkun
messages: + msg103893
2010-04-21 19:17:47iElectriccreate