classification
Title: urllib needs ability to set METHOD for HTTP requests
Type: enhancement Stage: resolved
Components: Library (Lib) Versions: Python 3.2
process
Status: closed Resolution: duplicate
Dependencies: Superseder: urllib2 requests history + HEAD support
View: 1673007
Assigned To: orsenthil Nosy List: aalex, brian.curtin, denversc, dstanek, orsenthil
Priority: normal Keywords:

Created on 2010-03-15 19:15 by aalex, last changed 2011-03-28 14:47 by brian.curtin. This issue is now closed.

Messages (4)
msg101133 - (view) Author: (aalex) Date: 2010-03-15 19:15
urllib.request can not support many standard HTTP 1.1 METHODS including HEAD, PUT, DELETE.

Adding this would be trivial (either as a special header "METHOD") or its own paramater, creating additional use, with little or no drawback.
msg112750 - (view) Author: David Stanek (dstanek) Date: 2010-08-04 04:00
In issue #1673007 I submitted a patch that enables the programmer to create a Request instance and specify the method to use.
msg132360 - (view) Author: Denver Coneybeare (denversc) * Date: 2011-03-27 19:43
Can this issue be closed as a duplicate of #1673007?  This specific request for a "method" parameter to the Request constructor is dealt with there.
msg132400 - (view) Author: Brian Curtin (brian.curtin) * (Python committer) Date: 2011-03-28 14:47
Closing as duplicate. #1673007 tackles the same issues and has a few patches available.
History
Date User Action Args
2011-03-28 14:47:13brian.curtinsetstatus: open -> closed

superseder: urllib2 requests history + HEAD support

nosy: + brian.curtin
messages: + msg132400
resolution: duplicate
stage: test needed -> resolved
2011-03-27 19:43:45denverscsetnosy: + denversc
messages: + msg132360
2010-08-04 04:00:23dstaneksetnosy: + dstanek
messages: + msg112750
2010-07-11 14:33:15BreamoreBoysetassignee: orsenthil
stage: test needed

nosy: + orsenthil
versions: - Python 3.1, Python 3.3
2010-03-15 19:15:05aalexcreate