classification
Title: Allow Arbitrary OpenID providers in this bug tracker
Type: enhancement Stage:
Components: None Versions:
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: georg.brandl, jcea, r.david.murray
Priority: Keywords:

Created on 2010-02-24 01:31 by jcea, last changed 2010-05-04 16:41 by jcea. This issue is now closed.

Messages (9)
msg99988 - (view) Author: Jesús Cea Avión (jcea) * (Python committer) Date: 2010-02-24 01:31
Currently the issue tracker only allows a handful of OpenID providers. The PYPI mailing list discussed the issue fo months, and finally PYPI opened to any OpenID provider. I would suggest to allow the same liberty, for the same reasons, here.
msg99990 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-02-24 01:35
Looking at the interface I assumed that any openid provider was supported.  Did you try an alternate one and it didn't work?  I'm using an id hosted on my own server (albeit delegating to myopenid).

This bug actually belongs in the metatracker, by the way.  (Which, unfortunately, doesn't support openid, but one thing at a time :)
msg99992 - (view) Author: Jesús Cea Avión (jcea) * (Python committer) Date: 2010-02-24 01:48
Trying to associate an "unsupported" OpenID provider is ignored.

There is no "link" to login with an "unsuppported" OpenID provider.

And yes, the report should be in the metatracker, but I don't have an account there, and they don't support OpenID at all (we do, so this "bug" belongs here :))
msg99994 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-02-24 02:02
Well, 'we' and 'they' are pretty much the same team.  If you want to enhance the openid support that Martin added to the tracker, you can submit a patch against the code in the repository.
msg100112 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2010-02-25 22:13
Closing as invalid -- how can we ask submitters to respect the rules if not even we committers do?
msg100136 - (view) Author: Jesús Cea Avión (jcea) * (Python committer) Date: 2010-02-26 04:38
Greog, please, elaborate. I want to learn :)
msg100140 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2010-02-26 08:27
I'm sorry, I was too short. I just meant that we should submit issues to the correct tracker :)
msg104958 - (view) Author: Jesús Cea Avión (jcea) * (Python committer) Date: 2010-05-04 16:40
Someway, the closed state vanished.
msg104959 - (view) Author: Jesús Cea Avión (jcea) * (Python committer) Date: 2010-05-04 16:41
Uhmmm... My browser seems crazy.
History
Date User Action Args
2010-05-04 16:41:21jceasetnosy: + georg.brandl, r.david.murray
messages: + msg104959
2010-05-04 16:40:30jceasetpriority: normal ->
nosy: - georg.brandl, r.david.murray
messages: + msg104958

2010-02-26 08:27:54georg.brandlsetmessages: + msg100140
2010-02-26 04:38:22jceasetmessages: + msg100136
2010-02-25 22:13:19georg.brandlsetstatus: open -> closed

nosy: + georg.brandl
messages: + msg100112

resolution: not a bug
2010-02-24 02:02:48r.david.murraysetpriority: normal

messages: + msg99994
2010-02-24 01:48:23jceasetmessages: + msg99992
2010-02-24 01:35:27r.david.murraysetnosy: + r.david.murray
messages: + msg99990
2010-02-24 01:31:59jceasettitle: Allow Arbitrary OpenID providers -> Allow Arbitrary OpenID providers in this bug tracker
2010-02-24 01:31:19jceacreate