classification
Title: Shelf 'keyencoding' keyword argument is undocumented and does not work.
Type: Stage: patch review
Components: Documentation, Library (Lib) Versions: Python 3.2
process
Status: closed Resolution: fixed
Dependencies: Superseder:
Assigned To: docs@python Nosy List: eric.araujo, georg.brandl, r.david.murray
Priority: low Keywords: needs review, patch

Created on 2010-02-11 03:14 by r.david.murray, last changed 2010-12-04 11:13 by georg.brandl. This issue is now closed.

Files
File name Uploaded Description Edit
shelve_keyencoding.patch r.david.murray, 2010-02-11 03:14 review
Messages (4)
msg99193 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-02-11 03:13
While working on another shelve issue I noticed that the keyencoding keyword argument was added to shelf, but that the value is hardcoded to 'utf-8' in the __init__ body.  DbfilenameShelf does not have a keyencoding option, nor does open, but BsdDbShelf does.  It seems to me that keyencoding was intended to be exposed but the work was not completed.  However I could be wrong...in which case the module should probably just use sys.getdefaultencoding.

I've prepared a patch that fixes the hardcoding bug and adds docs for the places where the keyword argument is currently accepted.  If this argument is kept and is documented, it should presumably be added to DbfilenameShelf and open as well.
msg102906 - (view) Author: Éric Araujo (eric.araujo) * (Python committer) Date: 2010-04-11 22:36
One remark: In “The *keyencoding* parameter is the encoding used to encode key values”, what are “key values”? Don’t we just say “keys” in such cases?

Regards
msg102912 - (view) Author: R. David Murray (r.david.murray) * (Python committer) Date: 2010-04-12 00:23
Yes, that would be clearer wording.
msg123336 - (view) Author: Georg Brandl (georg.brandl) * (Python committer) Date: 2010-12-04 11:13
Patched up and committed in r87024.
History
Date User Action Args
2010-12-04 11:13:02georg.brandlsetstatus: open -> closed
resolution: fixed
messages: + msg123336

versions: - Python 3.1
2010-10-29 10:07:21adminsetassignee: georg.brandl -> docs@python
2010-04-12 00:23:09r.david.murraysetkeywords: patch, patch, needs review

messages: + msg102912
2010-04-11 22:36:04eric.araujosetmessages: + msg102906
2010-02-16 04:54:21eric.araujosetnosy: + eric.araujo
2010-02-11 03:14:03r.david.murraycreate