classification
Title: test_readline failure
Type: behavior Stage: needs patch
Components: Library (Lib) Versions: Python 3.2, Python 2.7, Python 2.6
process
Status: closed Resolution: out of date
Dependencies: Superseder:
Assigned To: Nosy List: ark3, barry, binbrain, pitrou
Priority: normal Keywords:

Created on 2010-01-29 14:01 by pitrou, last changed 2010-11-20 22:05 by barry. This issue is now closed.

Messages (6)
msg98508 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2010-01-29 14:01
This is a fresh py3k checkout on a fresh Debian Lenny install:

======================================================================
ERROR: testHistoryUpdates (test.test_readline.TestHistoryManipulation)
----------------------------------------------------------------------
Traceback (most recent call last):
  File "/home/antoine/py3k/py3k/Lib/test/test_readline.py", line 16, in testHistoryUpdates
    readline.clear_history()
AttributeError: 'module' object has no attribute 'clear_history'

----------------------------------------------------------------------
msg100673 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2010-03-08 22:04
I see this in 2.6 also, Ubuntu 9.10 and 10.04 (alpha).  Marking this a release blocker for now, though I'll check to see if it's a regression or not.
msg121733 - (view) Author: Abhay Saxena (ark3) Date: 2010-11-20 19:35
Works for me with a fresh py3k on Ubuntu.
msg121736 - (view) Author: Jim Pharis (binbrain) Date: 2010-11-20 19:37
Unable to recreate this in Ubuntu 10.04 w/3.2 alpha 4. Tried with and without readline lib installed.
msg121755 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2010-11-20 20:20
I can't reproduce anymore (Debian 5.0.6). Barry?
msg121791 - (view) Author: Barry A. Warsaw (barry) * (Python committer) Date: 2010-11-20 22:05
I can't reproduce it either any more on Ubuntu 10.10 in either 2.6 or py3k.
History
Date User Action Args
2010-11-20 22:05:29barrysetstatus: pending -> closed
resolution: out of date
messages: + msg121791
2010-11-20 20:20:57pitrousetstatus: open -> pending

messages: + msg121755
2010-11-20 19:37:28binbrainsetnosy: + binbrain
messages: + msg121736
2010-11-20 19:35:35ark3setnosy: + ark3
messages: + msg121733
2010-03-09 02:44:14barrysetpriority: release blocker -> normal
2010-03-08 22:04:33barrysetpriority: normal -> release blocker
versions: + Python 2.6, Python 2.7
nosy: + barry

messages: + msg100673
2010-01-29 14:01:36pitroucreate