classification
Title: Wrong link in HTML documentation
Type: Stage: resolved
Components: Documentation Versions: Python 3.1
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: georg.brandl Nosy List: ezio.melotti, francescor, georg.brandl, july
Priority: low Keywords:

Created on 2010-01-12 17:01 by francescor, last changed 2010-01-12 18:02 by ezio.melotti. This issue is now closed.

Messages (4)
msg97635 - (view) Author: Francesco Ricciardi (francescor) Date: 2010-01-12 17:01
The first page of the Python Tutorial in version 3.1 (http://docs.python.org/3.1/tutorial/index.html) has the "previous topic" link pointing to "What’s New in Python 2.0" instead of "What’s New in Python 3.1".
msg97637 - (view) Author: July Tikhonov (july) * Date: 2010-01-12 17:55
I don't see anything wrong in this fact..

All "what's new" pages since python 2.0 are keeped in documentation, not only the last one.
msg97638 - (view) Author: Francesco Ricciardi (francescor) Date: 2010-01-12 17:57
As written in the description, it should point to the "What's New in Python 3.1" page, shouldn't it?
msg97639 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2010-01-12 18:02
The section before the tutorial is the "What's new" and there all the "What's new" pages are listed starting from 3.1 to 2.0 in descending order.
The "What's new in Python 2.0" is therefore the last page in the "What's new" section so the link in the tutorial points there.
It shouldn't point to the 3.1 page, but maybe the "previous/next topic" links shouldn't be visible in the first/last page of the section.
History
Date User Action Args
2010-01-12 18:02:01ezio.melottisetstatus: open -> closed
priority: low


nosy: + ezio.melotti
messages: + msg97639
resolution: not a bug
stage: resolved
2010-01-12 17:57:35francescorsetmessages: + msg97638
2010-01-12 17:55:27julysetnosy: + july
messages: + msg97637
2010-01-12 17:01:38francescorcreate