classification
Title: HP-UX 11.11 GCC build fails to build modules
Type: compile error Stage:
Components: Build Versions: Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: cannot find -lpythonX.X when building Python on FreeBSD with --enable-shared
View: 4366
Assigned To: Nosy List: Arfrever, rtarnell
Priority: normal Keywords:

Created on 2009-12-18 08:34 by rtarnell, last changed 2014-02-03 20:11 by Arfrever. This issue is now closed.

Messages (3)
msg96552 - (view) Author: River Tarnell (rtarnell) Date: 2009-12-18 08:34
2.6.4 fails to build on HP-UX 11.11 using GCC, when linking modules:

building '_struct' extension
gcc -pthread -shared build/temp.hp-ux-B.11.11-9000-785-2.6/home/river/
Python-2.6.4/Modules/_struct.o -L/opt/rt/lib -L/usr/local/lib -
lpython2.6 -o build/lib.hp-ux-B.11.11-9000-785-2.6/_struct.sl
/usr/ccs/bin/ld: Can't find library: "python2.6"
collect2: ld returned 1 exit status

(This happens for all modules.)

The problem is that libpython2.6.sl is in the root directory, but -L. 
is not passed to gcc, so the linker can't find the library.
msg112900 - (view) Author: Mark Lawrence (BreamoreBoy) * Date: 2010-08-04 21:32
Is anyone aware of build issues on HP-UX with later versions of Python?
msg210159 - (view) Author: Arfrever Frehtes Taifersar Arahesis (Arfrever) * (Python triager) Date: 2014-02-03 20:11
It is most likely a duplicate of bug #4366.
History
Date User Action Args
2014-02-03 20:11:36Arfreversetstatus: open -> closed

nosy: + Arfrever
messages: + msg210159

superseder: cannot find -lpythonX.X when building Python on FreeBSD with --enable-shared
resolution: duplicate
2014-02-03 19:50:40BreamoreBoysetnosy: - BreamoreBoy
2010-08-04 21:32:34BreamoreBoysetnosy: + BreamoreBoy
messages: + msg112900
2009-12-18 08:34:18rtarnellcreate