classification
Title: IDLE Subprocess Startup Error {Solved}
Type: crash Stage:
Components: IDLE Versions: Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: THRlWiTi, amaury.forgeotdarc
Priority: normal Keywords:

Created on 2009-10-27 07:57 by THRlWiTi, last changed 2009-11-04 17:21 by amaury.forgeotdarc. This issue is now closed.

Messages (5)
msg94546 - (view) Author: Thrlwiti (THRlWiTi) Date: 2009-10-27 07:57
Hi

After trying to install another IDE for python (Eric4.3.8 and sciTE201)
I'm not able to launch IDLE directly anymore. (I not sure if this is
really relevant)

I can right click on the .py files and choose "edit with IDLE" and
everything works fine.

Also, I can run python under cmd without any problem.

But when I try to open IDLE using start menu icon, this error massage
appears:

Subprocess Startup Error
IDLE's subprocess didn't make connection. either idle can't start a
subprocess or personal firewall software is blocking the connection.

I tried to disable my anti-virus and windows firewall (I don't use any
other firewalls), but the problem still exists.

I uninstalled python 2.6.2 and then installed python 3.1.1. IDLE worked
fine but I had a little problem with the new syntax in python 3 so I
installed python 2.6.4 and guess what, the same error message again!

When I try to run IDLE from cmd this error message is displayed:

hi
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "C:\Python26\lib\idlelib\run.py", line 13, in <module>
    import RemoteDebugger
  File "C:\Python26\lib\idlelib\RemoteDebugger.py", line 24, in <module>
    import rpc
  File "C:\Python26\lib\idlelib\rpc.py", line 120, in <module>
    request_queue = Queue.Queue(0)
TypeError: __init__() takes exactly 1 argument (2 given)

Can anyone help?
Thanks in advance
msg94547 - (view) Author: Thrlwiti (THRlWiTi) Date: 2009-10-27 07:59
I'm using windows vista  x64
I've tried restarting my computer and manually deleting files but didn't
help.
msg94786 - (view) Author: Thrlwiti (THRlWiTi) Date: 2009-11-01 12:52
?
msg94873 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2009-11-04 00:33
Do you have some Queue.py in your PYTHONPATH, before the standard one?
What do you get when starting python from cmd:
  import Queue
  print Queue
(It should be <module 'Queue' from 'C:\Python26\lib\Queue.pyc'>)
msg94891 - (view) Author: Thrlwiti (THRlWiTi) Date: 2009-11-04 15:57
{Solved}
Thanks for following up Amaury
But my problem was solved yesterday.
There was a few programs in the main python directory which I didn't
want to delete, so I moved them to another directory and manually
deleted C:\Python26 and then restarted my computer. After installing
python again, the problem was solved.
Thanks again
History
Date User Action Args
2009-11-04 17:21:00amaury.forgeotdarcsetstatus: open -> closed
resolution: not a bug
2009-11-04 15:57:52THRlWiTisetmessages: + msg94891
title: IDLE Subprocess Startup Error -> IDLE Subprocess Startup Error {Solved}
2009-11-04 00:33:05amaury.forgeotdarcsetnosy: + amaury.forgeotdarc
messages: + msg94873
2009-11-01 12:52:05THRlWiTisetmessages: + msg94786
2009-10-27 07:59:47THRlWiTisetmessages: + msg94547
2009-10-27 07:57:04THRlWiTicreate