classification
Title: test_distutils failure
Type: behavior Stage: needs patch
Components: Distutils, Tests Versions: Python 3.1
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: tarek Nosy List: flox, pitrou, tarek
Priority: normal Keywords: buildbot

Created on 2009-09-21 21:36 by pitrou, last changed 2010-01-15 17:03 by flox. This issue is now closed.

Messages (5)
msg92963 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2009-09-21 21:36
I get the following (deterministic) failure on the py3k branch:

test_distutils
0 blocks
find:
`/home/antoine/tmp/tmpX6PtRb/foo/build/bdist.linux-x86_64/rpm/BUILDROOT/foo-0.1-1.x86_64/usr/lib/debug':
Aucun fichier ou dossier de ce type
0 blocks
find:
`/home/antoine/tmp/tmpNJkuVH/foo/build/bdist.linux-x86_64/rpm/BUILDROOT/foo-0.1-1.x86_64/usr/lib/debug':
Aucun fichier ou dossier de ce type
test test_distutils failed -- Traceback (most recent call last):
  File "/home/antoine/py3k/__svn__/Lib/distutils/tests/test_util.py",
line 145, in test_get_platform
    self.assertEquals(get_platform(), 'macosx-10.4-universal')
AssertionError: 'macosx-10.4-intel' != 'macosx-10.4-universal'

1 test failed:
    test_distutils
msg92965 - (view) Author: Antoine Pitrou (pitrou) * (Python committer) Date: 2009-09-21 21:46
It also fails on release31-maint, but not on trunk.
msg92979 - (view) Author: Tarek Ziadé (tarek) * (Python committer) Date: 2009-09-22 10:15
That was fixed already in trunk, and a pending merging waiting to be
merged. I've just merged in r75013 and r75014
msg97824 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2010-01-15 16:59
There's still similar failures on 3.1 branch only.
Some buildbots which have reported the error:
  AMD64 Ubuntu
  ia64 Ubuntu
  alpha Debian
  AMD64 Gentoo

http://www.python.org/dev/buildbot/all/builders/AMD64%20Ubuntu%203.1/builds/194
http://www.python.org/dev/buildbot/all/builders/ia64%20Ubuntu%203.1/builds/227

test test_distutils failed -- Traceback (most recent call last):
  File "/home/buildbot/slave/py-build/3.1.norwitz-amd64/build/Lib/distutils/tests/test_util.py", line 99, in test_get_platform
    self.assertEquals(get_platform(), 'macosx-10.3-i386')
AssertionError: 'macosx-10.3-x86_64' != 'macosx-10.3-i386'
msg97825 - (view) Author: Florent Xicluna (flox) * (Python committer) Date: 2010-01-15 17:03
whoops... I missed #7591 which is a report for the same issue.
History
Date User Action Args
2010-01-15 17:03:11floxsetstatus: open -> closed
resolution: not a bug
messages: + msg97825
2010-01-15 16:59:02floxsetstatus: closed -> open

versions: - Python 3.2
keywords: + buildbot
nosy: + flox

messages: + msg97824
resolution: not a bug -> (no value)
2009-09-22 10:15:03tareksetstatus: open -> closed
resolution: not a bug
messages: + msg92979
2009-09-21 21:46:00pitrousetmessages: + msg92965
versions: + Python 3.1
2009-09-21 21:36:16pitroucreate