classification
Title: Threading issue with Tkinter Frame.insert
Type: behavior Stage: resolved
Components: Tkinter Versions: Python 2.6
process
Status: closed Resolution: not a bug
Dependencies: Superseder:
Assigned To: Nosy List: Ramchandra Apte, moraygrieve, serhiy.storchaka, terry.reedy
Priority: normal Keywords:

Created on 2009-09-17 17:01 by moraygrieve, last changed 2013-03-08 21:53 by terry.reedy. This issue is now closed.

Files
File name Uploaded Description Edit
example.py moraygrieve, 2009-09-17 17:00
Messages (5)
msg92781 - (view) Author: Moray Grieve (moraygrieve) Date: 2009-09-17 17:00
The attached file has an example where a Tk GUI is launched as a
seperate thread - this all works fine in Python 2.5, but in Python 2.6
the thread hangs. 

The issue seems to be in the line;

self.messageBoxDetails.insert(INSERT, "Hello world")

Comment this line out, or use an empty string rather than "Hello World",
and the example works in both Python 2.5 and Python 2.6. I have not been
able to seen any related issues to this and wonder if this is a bug in
the 2.6 Tkinter module.
msg92782 - (view) Author: Moray Grieve (moraygrieve) Date: 2009-09-17 17:04
I should say this is running on Windows XP
msg174639 - (view) Author: Ramchandra Apte (Ramchandra Apte) * Date: 2012-11-03 15:47
Bump.
msg180034 - (view) Author: Serhiy Storchaka (serhiy.storchaka) * (Python committer) Date: 2013-01-15 16:34
Tkinter as perhaps any other GUI library must be used only from one thread.
msg183767 - (view) Author: Terry J. Reedy (terry.reedy) * (Python committer) Date: 2013-03-08 21:53
Quoting from msg179101 on #16823, which I turned into a doc issue:
'''
What you are doing appears to be unsupported (invalid). From
http://www.astro.washington.edu/users/rowen/TkinterSummary.html
"all Tkinter access must be from the main thread (or more precisely,
from the thread that calls the mainloop). Violating this is likely to
cause nasty and mysterious symptoms such as freezes and core dumps."
'''
You got the freeze part. I suspect what changed from 2.5 to 2.6 was the tcl/tk version delivered with Python on Windows.
History
Date User Action Args
2013-03-08 21:53:48terry.reedysetstatus: open -> closed
resolution: not a bug
messages: + msg183767

stage: resolved
2013-01-15 16:34:00serhiy.storchakasetnosy: + terry.reedy, serhiy.storchaka
messages: + msg180034
2012-11-03 15:47:34Ramchandra Aptesetnosy: + Ramchandra Apte
messages: + msg174639
2009-09-17 17:04:23moraygrievesetmessages: + msg92782
2009-09-17 17:01:00moraygrievecreate