classification
Title: hotshot stats load causes TypeError when multiple files are loaded
Type: behavior Stage: resolved
Components: Library (Lib) Versions: Python 2.6
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Regression in pstats
View: 7372
Assigned To: Nosy List: alexandre.vassalotti, ezio.melotti, fdrake, georg.brandl, j1m, therve
Priority: normal Keywords:

Created on 2009-08-15 22:12 by j1m, last changed 2010-01-26 00:25 by ezio.melotti. This issue is now closed.

Files
File name Uploaded Description Edit
hotshotbug.py j1m, 2009-08-15 22:12
Messages (4)
msg91619 - (view) Author: Jim Fulton (j1m) * (Python committer) Date: 2009-08-15 22:12
I've attached a script that demonstrates the problem.  When run with
Python 2.5, it outputs statistics.  When run with Python 2.6.2 it
generates a TypeError:

python2.6 hotshotbug.py
Traceback (most recent call last):
  File "hotshotbug.py", line 5, in <module>
    stats.add(hotshot.stats.load('p2'))
  File "/usr/local/python/2.6/lib/python2.6/pstats.py", line 171, in add
    self.stats[func] = add_func_stats(old_func_stat, stat)
  File "/usr/local/python/2.6/lib/python2.6/pstats.py", line 516, in
add_func_stats
    add_callers(t_callers, callers))
  File "/usr/local/python/2.6/lib/python2.6/pstats.py", line 526, in
add_callers
    zip(caller, new_callers[func])])
TypeError: zip argument #1 must support iteration
msg91620 - (view) Author: Jim Fulton (j1m) * (Python committer) Date: 2009-08-15 22:13
Fred might be interested. :)
msg96886 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2009-12-25 20:37
The change that causes this problem has been introduced in r60149 to fix
#1269.
msg98305 - (view) Author: Ezio Melotti (ezio.melotti) * (Python committer) Date: 2010-01-26 00:25
This is a duplicate of #7372.
History
Date User Action Args
2010-01-26 00:25:36ezio.melottisetstatus: open -> closed
resolution: duplicate
messages: + msg98305

superseder: Regression in pstats
stage: test needed -> resolved
2010-01-12 00:22:54alexandre.vassalottisetnosy: + alexandre.vassalotti
2009-12-25 20:37:53ezio.melottisetpriority: normal

nosy: + ezio.melotti, georg.brandl, therve
messages: + msg96886

stage: test needed
2009-08-15 22:13:26j1msetnosy: + fdrake
messages: + msg91620
2009-08-15 22:12:16j1mcreate