classification
Title: During compiling python 3.1 getting error Undefined symbol libintl_bind_textdomain_codeset
Type: compile error Stage: resolved
Components: Installation Versions: Python 3.1
process
Status: closed Resolution: duplicate
Dependencies: Superseder: Python doesn't compile anymore on our Solaris buildbot: undefined libintl_* symbols
View: 13843
Assigned To: Nosy List: amaury.forgeotdarc, skrah, thoratsandip
Priority: normal Keywords:

Created on 2009-08-01 21:37 by thoratsandip, last changed 2012-02-05 10:04 by skrah. This issue is now closed.

Messages (6)
msg91170 - (view) Author: Sandip Thorat (thoratsandip) Date: 2009-08-01 21:37
Hi 

I am installing Python-3.1 on "SunOS sunx7qa 5.10 Generic_127112-06 
i86pc i386 i86pc".

./configure  done without any error.

But 'make' throwing folloing error:



gcc -c -fno-strict-aliasing -DNDEBUG -g -fwrapv -O3 -Wall -Wstrict-
prototypes  -I. -IInclude -I./Include  -DPy_BUILD_CORE -
DSVNVERSION="\"`LC_ALL=C echo Unversioned directory`\"" -o 
Modules/getbuildinfo.o ./Modules/getbuildinfo.c
rm -f libpython3.1.a
ar rc libpython3.1.a Modules/getbuildinfo.o
ar rc libpython3.1.a Parser/acceler.o  Parser/grammar1.o  
Parser/listnode.o  Parser/node.o  Parser/parser.o  Parser/parsetok.o  
Parser/bitset.o  Parser/metagrammar.o  Parser/firstsets.o  
Parser/grammar.o  Parser/pgen.o Parser/myreadline.o Parser/tokenizer.o
ar rc libpython3.1.a Objects/abstract.o  Objects/boolobject.o  
Objects/bytes_methods.o  Objects/bytearrayobject.o  
Objects/bytesobject.o  Objects/cellobject.o  Objects/classobject.o  
Objects/cobject.o  Objects/codeobject.o  Objects/complexobject.o  
Objects/descrobject.o  Objects/enumobject.o  Objects/exceptions.o  
Objects/genobject.o  Objects/fileobject.o  Objects/floatobject.o  
Objects/frameobject.o  Objects/funcobject.o  Objects/iterobject.o  
Objects/listobject.o  Objects/longobject.o  Objects/dictobject.o  
Objects/memoryobject.o  Objects/methodobject.o  Objects/moduleobject.o  
Objects/object.o  Objects/obmalloc.o  Objects/capsule.o  
Objects/rangeobject.o  Objects/setobject.o  Objects/sliceobject.o  
Objects/structseq.o  Objects/tupleobject.o  Objects/typeobject.o  
Objects/unicodeobject.o  Objects/unicodectype.o  Objects/weakrefobject.o
ar rc libpython3.1.a Python/_warnings.o  Python/Python-ast.o  
Python/asdl.o  Python/ast.o  Python/bltinmodule.o  Python/ceval.o  
Python/compile.o  Python/codecs.o  Python/errors.o  Python/frozen.o  
Python/frozenmain.o  Python/future.o  Python/getargs.o  
Python/getcompiler.o  Python/getcopyright.o  Python/getplatform.o  
Python/getversion.o  Python/graminit.o  Python/import.o  
Python/importdl.o  Python/marshal.o  Python/modsupport.o  
Python/mystrtoul.o  Python/mysnprintf.o  Python/peephole.o  
Python/pyarena.o  Python/pyctype.o  Python/pyfpe.o  Python/pymath.o  
Python/pystate.o  Python/pythonrun.o  Python/structmember.o  
Python/symtable.o  Python/sysmodule.o  Python/traceback.o  
Python/getopt.o  Python/pystrcmp.o  Python/pystrtod.o  Python/dtoa.o  
Python/formatter_unicode.o  Python/dynload_shlib.o      Python/thread.o
ar rc libpython3.1.a Modules/config.o  Modules/getpath.o  
Modules/main.o  Modules/gcmodule.o
ar rc libpython3.1.a Modules/_threadmodule.o  Modules/signalmodule.o  
Modules/posixmodule.o  Modules/errnomodule.o  Modules/pwdmodule.o  
Modules/_sre.o  Modules/_codecsmodule.o  Modules/_weakref.o  
Modules/_functoolsmodule.o  Modules/_localemodule.o  
Modules/_iomodule.o Modules/iobase.o Modules/fileio.o Modules/bytesio.o 
Modules/bufferedio.o Modules/textio.o Modules/stringio.o  
Modules/zipimport.o  Modules/symtablemodule.o  Modules/xxsubtype.o
ranlib libpython3.1.a
gcc   -o python \
                Modules/python.o \
                libpython3.1.a -lresolv -lsocket -lnsl -lrt -ldl   -lm
Undefined                       first referenced
 symbol                             in file
libintl_bind_textdomain_codeset     libpython3.1.a(_localemodule.o)
libintl_gettext                     libpython3.1.a(_localemodule.o)
libintl_textdomain                  libpython3.1.a(_localemodule.o)
libintl_dcgettext                   libpython3.1.a(_localemodule.o)
libintl_bindtextdomain              libpython3.1.a(_localemodule.o)
libintl_dgettext                    libpython3.1.a(_localemodule.o)
ld: fatal: Symbol referencing errors. No output written to python
collect2: ld returned 1 exit status
*** Error code 1
make: Fatal error: Command failed for target `python'
bash-3.00$ pwd


Need your help to resolve this issue.
msg91421 - (view) Author: Sandip Thorat (thoratsandip) Date: 2009-08-08 16:32
Plz assist to install Python on Solaris_x86
msg91758 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2009-08-20 00:28
I dont know Solaris, but googling for "libintl_textdomain solaris" shows 
that many other projects have the same issue.
The solution seems to set LDFLAGS=-lintl
msg92500 - (view) Author: Sandip Thorat (thoratsandip) Date: 2009-09-10 23:47
Which file do i edit to add LDFLAGS=-lintl  ?

and at what place?
msg92508 - (view) Author: Amaury Forgeot d'Arc (amaury.forgeotdarc) * (Python committer) Date: 2009-09-11 09:59
I'm not a Unix expert at all, but did you try to export the variable?
    export LDFLAGS=-lintl
then "configure" and "make".
msg152669 - (view) Author: Stefan Krah (skrah) * (Python committer) Date: 2012-02-05 10:04
I'm tagging this as a duplicate of #13843, since I expect more activity
on the newer issue.
History
Date User Action Args
2012-02-05 10:04:46skrahsetstatus: open -> closed

superseder: Python doesn't compile anymore on our Solaris buildbot: undefined libintl_* symbols

nosy: + skrah
messages: + msg152669
resolution: duplicate
stage: resolved
2009-09-11 09:59:36amaury.forgeotdarcsetmessages: + msg92508
2009-09-10 23:47:03thoratsandipsetmessages: + msg92500
2009-08-20 00:28:21amaury.forgeotdarcsetnosy: + amaury.forgeotdarc
messages: + msg91758
2009-08-08 16:32:55thoratsandipsetmessages: + msg91421
2009-08-01 21:37:56thoratsandipcreate